Find the answer to your Linux question:
Results 1 to 8 of 8
I'm trying to boot the first install CD for Slackware 13.1 on an AMD K6 system. It only goes partway through the boot, then hangs. System info (running Debian Lenny ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Location
    Santa Cruz, California
    Posts
    76

    Red face Slackware 13.1 install CD won't boot on K6 system with huge.s kernel


    I'm trying to boot the first install CD for Slackware 13.1 on an AMD K6 system. It only goes partway through the boot, then hangs.

    System info (running Debian Lenny with xfce4 now, previously was running Ubuntu 6.06 LTS with no X):

    Debian GNU/Linux 5.0
    Linux slug 2.6.26-2-486 #1 Mon Jun 21 05:12:58 UTC 2010 i586 GNU/Linux
    model name : AMD-K6(tm) 3D processor
    stepping : 12
    cpu MHz : 400.920
    MemTotal: 126620 kB
    MemFree: 13920 kB

    My response to the boot prompt is

    boot: huge.s

    What happens is the boot gets to these 2 lines (copied down by hand) and then the process hangs up:

    Loading iSCSI transport class v2.0-870.
    fnic: Cisco FCoE HBA Driver, ver 1.0.0.1121

    lspci (on Debian) shows:

    00:00.0 Host bridge: VIA Technologies, Inc. VT82C598 [Apollo MVP3] (rev 04)
    00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
    00:07.0 ISA bridge: VIA Technologies, Inc. VT82C586/A/B PCI-to-ISA [Apollo VP] (rev 47)
    00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
    00:07.3 Non-VGA unclassified device: VIA Technologies, Inc. VT82C586B ACPI (rev 10)
    00:08.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
    00:09.0 USB Controller: NEC Corporation USB (rev 41)
    00:09.1 USB Controller: NEC Corporation USB (rev 41)
    00:09.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
    00:0a.0 Multimedia audio controller: ESS Technology ES1988 Allegro-1 (rev 10)
    01:00.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 (rev 01)

    Existing disk partitions are formatted with ext3 file systems.

    I can provide further information on the system, if needed.

  2. #2
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    878
    AMD K6 is a i586 CPU, code and kernel built for i686 will not work. Is the Slackware you are trying to install meant for i686?

  3. #3
    Just Joined!
    Join Date
    Mar 2009
    Location
    Santa Cruz, California
    Posts
    76
    No. the huge.s kernel, which I was booting, is a 486 kernel. The default kernel is a 686 kernel.

    If I try to boot the default kernel, it doesn't get that far - it almost immediately complains about the lack of a couple of instructions. But that's not this problem - huge.s is supposed to work on all 486 and above CPUs.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2009
    Location
    Santa Cruz, California
    Posts
    76
    I have two other AMD K6 systems, both of which have more RAM, and I can boot the install disk with the huge.s 486 kernel. I actually haven't tried installing on these systems yet. So the RAM sizes on each system are:

    #1 126.620 MB (The system that failed)
    #2 159.096 MB
    #3 509.276 MB

    The 3 systems have entirely different motherboards, but I suspect the memory size to be the main issue.

  6. #5
    Just Joined!
    Join Date
    Aug 2010
    Posts
    5
    Quote Originally Posted by velikij View Post
    I have two other AMD K6 systems, both of which have more RAM, and I can boot the install disk with the huge.s 486 kernel. I actually haven't tried installing on these systems yet. So the RAM sizes on each system are:

    #1 126.620 MB (The system that failed)
    #2 159.096 MB
    #3 509.276 MB

    The 3 systems have entirely different motherboards, but I suspect the memory size to be the main issue.
    Something worth trying would be to try a small kernel with an initscript that starts swap as early as possible. 126 should be plenty to boot, but I'd look for a smaller kernel that isn't loading so many drivers you won't be needing.
    After a bit of research, you may need to compile one from source (which I recommend anyway).

  7. #6
    Just Joined!
    Join Date
    Mar 2009
    Location
    Santa Cruz, California
    Posts
    76
    Quote Originally Posted by quizno50 View Post
    Something worth trying would be to try a small kernel with an initscript that starts swap as early as possible. 126 should be plenty to boot, but I'd look for a smaller kernel that isn't loading so many drivers you won't be needing.
    After a bit of research, you may need to compile one from source (which I recommend anyway).
    That sounds like a good strategy, IF I were willing to expend that much time on that particular computer. Instead I installed Slackware on a second drive on the system with the most memory and disk space, and it dual-boots with Ubuntu, using Ubuntu's Grub-2 boot loader (which detects the Slackware kernel and partitions). So I got the experience of installing and configuring Slackware, which was my goal. I was able to run both KDE and xfce window managers, with a choice of several more, I see.

    Regarding the original system - kernel compilation would have to be done on a separate system, since the install kernel won't boot. Perhaps there's a boot option for activating a swap partition when starting the install disk?

    On the system in question, I'm running Debian Lenny. Its installer has the option of only installing the drivers needed for that hardware, and I chose that.

    Thanks for the suggestions!

  8. #7
    Just Joined!
    Join Date
    Aug 2010
    Posts
    5
    Perhaps there's a boot option for activating a swap partition when starting the install disk?
    It looked like from your original posts that your kernel wasn't even finished booting. Unfortunately I don't think it's possible to start swap space before the kernel's even loaded. However you might try looking around in /etc/inittab and putting a:
    Code:
    swapon -a
    as the first line processed in the bootup sequence maybe worth looking at.
    You may want to look at the inittab manpage to double check the format of the file.

    Good luck!

  9. #8
    Just Joined!
    Join Date
    Mar 2009
    Location
    Santa Cruz, California
    Posts
    76
    Quote Originally Posted by quizno50 View Post
    It looked like from your original posts that your kernel wasn't even finished booting. Unfortunately I don't think it's possible to start swap space before the kernel's even loaded. However you might try looking around in /etc/inittab and putting a:
    Code:
    swapon -a
    as the first line processed in the bootup sequence maybe worth looking at.
    You may want to look at the inittab manpage to double check the format of the file.

    Good luck!
    Inittab can't be modified at that point. It's on the CD, I presume.

    As for the kernel, there may or may not be kernel boot options which can be added to just "huge.s" in the boot command line, which might enable the boot process to complete.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •