Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I apologize for the many questions, but here comes one more. I have 2 CD drives, one is a standard 56x... the other is a 52X CdRW burner. How do ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    Kentucky
    Posts
    36

    mounting CDrom and CDRW for a newbie


    I apologize for the many questions, but here comes one more.

    I have 2 CD drives, one is a standard 56x... the other is a 52X CdRW burner.

    How do I mount these? I've tried looking for a guide on the internet, but these require me to know something called "fstab", which I know nothing about.

  2. #2
    Linux Newbie
    Join Date
    Mar 2004
    Posts
    119
    fstab is a file located in /etc. it lists what partitions and drives to mount. You'll want to put your CD drives in that file. You can also use the "mount" command to just mount them right away.

    See "man mount" and "man fstab".

  3. #3
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Also, do you know what kernel you're using?
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  4. #4
    Just Joined!
    Join Date
    Jul 2004
    Location
    Kentucky
    Posts
    36
    whatever the default kernel of Slackware 10.0 is...... it's either 2.4.2 something, or 2.6. I think it is the former, however.

  5. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Chances are it's the 2.4.... kernel.

    Anyways, your Slack install should have added the cd-R to the /etc/fstab file.

    type

    less /etc/fstab to see the contents.

    An example would be

    /dev/hdc /mnt/cdrom iso???? user,ro 0 0 or summat like that.

    So all you have to do is add a data disk to the drive and type

    mount /mnt/cdrom

    You may get a permissions error, in which case add your user to the user group. If none exists add yourself to the users group and edit fstab to replace user with users.

    Then browse the filesystem using whatever you use and you should see the contents of the cd in /mnt/cdrom.

    If that works post back and we'll add your cd-rw to the system.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  6. #6
    Just Joined!
    Join Date
    Jul 2004
    Location
    Kentucky
    Posts
    36
    root@darkstar:/home/blackenedwaters# mount /mnt/cdrom
    mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
    or too many mounted file systems


    I keep getting that error.....

  7. #7
    Linux Newbie
    Join Date
    Mar 2004
    Posts
    119
    it might help to show us your fstab file.

  8. #8
    Just Joined!
    Join Date
    Jul 2004
    Location
    Kentucky
    Posts
    36
    /dev/hda3 swap swap defaults 0 0
    /dev/hda5 / ext2 defaults 1 1
    /dev/hda4 /home reiserfs defaults 1 2
    /dev/hda1 /windows vfat defaults 1 0
    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0

  9. #9
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Browse to your /dev directory and right - click - properties for cdrom. Where's it pointing to? And does where it's pointing to exist? It should be /dev/hdc if you have your cdrom attached in a typical manner.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  10. #10
    Just Joined!
    Join Date
    Aug 2004
    Posts
    19
    'mount' works like this:

    mount (options) (source) (destination)

    options: are the ones listed in your man pages. this include FStype, etc..

    source: is what you want to mount. in your case, your master cd drive
    would be '/dev/hdc' and slave '/dev/hdd'

    destination: is any folder (likely empty) in your filesystem where you
    want the device mounted. most likely, they are in '/mnt'

    to mount your master cd drive:
    mount /dev/hdc /mnt/cdrom0

    what you did wrong is you didn't tell 'mount' what to mount.

    i might be wrong in the words i used but i tried to explain it in a way anybody can understand. hope this helps

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •