Find the answer to your Linux question:
Results 1 to 1 of 1
I just downloaded and upgraded from seamonkey 2.0.8 to 2.0.9. It installed ok, but when I tried to create the symbolic link to the menu, it failed, just like my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2010
    Location
    Michigan
    Posts
    47

    Link creation fails--seamonkey upgrade


    I just downloaded and upgraded from seamonkey 2.0.8 to 2.0.9. It installed ok, but when I tried to create the symbolic link to the menu, it failed, just like my attempt to create a link when upgrading thunderbird failed (last week).
    Here's the code I used:

    Link not working:
    Konsole output:
    Code:
    root@darkstar:/usr/lib/seamonkey-2.0.9# ln  -sf /usr/lib/seamonkey-2.0.9/seamonkey  /usr/bin/seamonkey
    root@darkstar:/usr/lib/seamonkey-2.0.9# exit
    exit
    sandy@darkstar:~$ cd  /usr/lib/seamonkey-2.0.9/seamonkey
    sandy@darkstar:/usr/lib/seamonkey-2.0.9/seamonkey$ ./seamonkey  ---It comes up and works fine.
    sandy@darkstar:/usr/lib/seamonkey-2.0.9/seamonkey$ su
    Password:
    root@darkstar:/usr/lib/seamonkey-2.0.9/seamonkey# exit
    exit
    sandy@darkstar:/usr/lib/seamonkey-2.0.9/seamonkey$ ./seamonkey
    sandy@darkstar:/usr/lib/seamonkey-2.0.9/seamonkey$
    sandy@darkstar:~/Downloads/seamonkey-2.0.9/seamonkey$ ./seamonkey
    sandy@darkstar:~/Downloads/seamonkey-2.0.9/seamonkey$
    ----It comes up and works fine here too.
    I have a copy in my home directory and in the proper place, /usr/lib, and both come up and work fine. It's just that when I tried to create the link in /usr/lib/seamonkey-2.0.9, that the link did not go to the menu.
    I'm using the same code I used when I upgraded firefox, seamonkey to 2.0.0.8 and those links were created without a problem.
    What seems curious to me is that is can run both /usr/lib/seamonkey-2.0.9/seamonkey and /home/sandy/Downloads/seamonkey-2.0.9/seamonkey as "sandy", not as root. Does anyone know what the problem is?
    Last edited by MikeTbob; 10-22-2010 at 01:19 AM. Reason: Added code tags

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •