Find the answer to your Linux question:
Results 1 to 5 of 5
i want to use my slackware linux box as my work box but i cant get the printing to work. i tried it in RH9 and Slackware 10 and Slax ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    19

    printing


    i want to use my slackware linux box as my work box but i cant get the printing to work.

    i tried it in RH9 and Slackware 10 and Slax (it was fine with debian) and it gives my a message after running 'cupsd':
    "Child exited with status 98!". it was fine before with RH9 but recently it gave the same message.

    any help is appreciated. thanks a lot

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Sounds like cupsd is already running.

    First off if you did a full install of slack then chances are you installed lpr and cups. They conflict with each other. Easiest way is to remove both then reinstall cups.

    Then see what happens.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    That is true, i had the same problem. Slackware 10 installs both cups and lpr by defualt, but after i uninstalled both of them (cups, lpr), and then installed only cups, everything worked fine!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2004
    Posts
    19
    thanks.

    i did a full install of slackware 10 and everything was fine except the printing and sound, since i installed a tv tuner card (i hope you can help me with this)

    then i installed slax (slax.linux-live.org) on another partition. when i booted slax (through loadlin), it was fine. so i rebooted and tried to boot slack10 (again through loadlin, but different kernel image). it led me to a prompt saying 'diagnostic stuff' and prompted for a root password and recommended running e2fsck. now i'm stuck only with slax. any suggestions?

    if i can't find any solution, maybe i'll just reinstall everything. and then do what you taught me about cups and lpr. thanks a lot!

  6. #5
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    This is from an earlier post by me. This might be something to look into:

    We got the printer figured out - just in case anybody is interested Parallel port is not enabled in Slack 10 (it is on earlier versons). I uncommented the parallel port settings on rc.modules rebooted an viola printer. cool, but now we are trying to share it on the network. We went throught the configs in smb.conf but we are missing something. Please give suggestions that might work maybe we will stumble onto something.

    Good Luck
    Mike

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •