Find the answer to your Linux question:
Results 1 to 1 of 1
A little background first: Wireless card: Broadcom BCM4312 Wireless driver used: broadcom.com/support/802.11/linux_sta.php (and slackbuild variation of the same) GFX card: nVidia geForce 7150m I installed Slackware yesterday, along side my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2011
    Location
    Cornville, IN, USA
    Posts
    1

    Invalid module format (both wireless and GFX)


    A little background first:

    Wireless card: Broadcom BCM4312
    Wireless driver used: broadcom.com/support/802.11/linux_sta.php (and slackbuild variation of the same)
    GFX card: nVidia geForce 7150m

    I installed Slackware yesterday, along side my Ubuntu (yes yes, I use Ubuntu lol. I've been using it for about four years, and I'm pretty much still a Linux noob, and I'd like to change that; that's why I'm here.), with the help of a friend who has been using Slackware for a while. I added Slackware to grub.cfg, using the OS prober, which added four menu entries. The first two cause kernel panic, the third worked, and I don't think I tried the fourth. (I'm pretty sure they were, in this order: generic, generic-smp, huge, and huge-smp). Using huge, I could not modprobe my wireless driver, I would get a "Invalid Module Format" error with wl, and when installing the nVidia drivers (from their site), I would get:

    Unable to load kernel module 'nvidia.ko'. This happens most frequently when this kernel module was build against the wrong or improperly configured kernel sources, with a version of gcc that differes from the one used to build the target kernel, or if a driver such as rivafb nvidiafb or nouveau is present and prevents the NVIDIA module from obtaining ownership of the NVIDIA graphic(s) devices, or NVIDA GPU installed in this system is not supported by this NVIDIA Linux
    I then booted using a menuentry my friend gave me, created my initrd, and everything worked fine, both graphics and wireless (mostly fine). So I upgraded to -current, kernel 2.6.35.10, and I started getting the same errors as before, 'Invalid Module format' and the same thing with the nVidia drivers, although this time, it happens regardless of if I use the generic kernel, or the huge kernel.

    Now I am completely baffled by all of this. Any help is greatly appreciated, as I would really like to start using Slackware.

    Thanks.

    EDIT: Figured it out. Needed to apply a nosmp patch to the kernel sources.
    Last edited by tacticalbread; 01-26-2011 at 11:26 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •