Find the answer to your Linux question:
Results 1 to 5 of 5
Hello, I have a samba server up and running and 1 window box connect and all is well. I am trying to connect another windows computer through my linksys router ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    3

    samba and winxp


    Hello,
    I have a samba server up and running and 1 window box connect and all is well.

    I am trying to connect another windows computer through my linksys router and for some reason I can not get that machine to reconize the network.

    I added -- host allow 192.168.1.0/255.255.255.0
    both windows boxes have an IP address of 192.168.1.101 and 192.168.1.102 and my samba server is 192.168.1.100

    The .101 machines works the .102 does not.

    I have check all the user names and all matches the smbpasswd file on the slax box.

    Any suggestions or ideas?

  2. #2
    JR
    JR is offline
    Just Joined!
    Join Date
    Nov 2004
    Posts
    12
    are you trying to add them to a domain?

    try this on the samba machine & post the result:
    nmblookup -A 192.168.1.102

    next try this on the windows machine:
    nbtstat -A 192.168.1.100

    post your smb.conf file

    what version of windows is the machine running?
    if it is XP, then try disabling the built in firewall and try the above commands again.

    JR

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    3
    I tried pinging the slack .100 and the windoz .101 from the windoz .102 and request time out.

    Here what I found...


    ************************************************** **********
    Slackware Box
    ************************************************** **********
    root@dev:~# nmblookup -A 192.168.1.102
    Looking up status of 192.168.1.102
    PC103103209124 <00> - M <ACTIVE>
    MSGROUP <00> - <GROUP> M <ACTIVE>
    PC103103209124 <20> - M <ACTIVE>
    MSGROUP <1e> - <GROUP> M <ACTIVE>
    MSGROUP <1d> - M <ACTIVE>
    ..__MSBROWSE__. <01> - <GROUP> M <ACTIVE>

    MAC Address = 00-0F-B0-0F-CA-99



    ************************************************** **********
    Windoz XP box
    command run that I ran
    nbtstat -A 192.168.1.100
    ************************************************** **********
    Local Area Connection:
    Node IpAddress: [192.168.1.102] Scope Id: []
    * * * * * *NetBIOS Remote Machine Name Table
    * * * *Name * * * * * * * Type * * * * Status
    * * ---------------------------------------------
    * * DEV * * * * * *<00> *UNIQUE * * *Registered
    * * DEV * * * * * *<03> *UNIQUE * * *Registered
    * * DEV * * * * * *<20> *UNIQUE * * *Registered
    * * ..__MSBROWSE__.<01> *GROUP * * * Registered
    * * SLACKWARE_BOX *<00> *GROUP * * * Registered
    * * SLACKWARE_BOX *<1D> *UNIQUE * * *Registered
    * * SLACKWARE_BOX *<1E> *GROUP * * * Registered
    * * MAC Address = 00-00-00-00-00-00

    Wireless Network Connection:
    Node IpAddress: [0.0.0.0] Scope Id: []
    * * Host not found.


    smb.conf

    # Samba config file created using SWAT
    # from 127.0.0.1 (127.0.0.1)
    # Date: 2004/11/25 23:27:50

    # Global parameters
    [global]
    workgroup = slackware_box
    server string = Samba Server
    log file = /var/log/samba.%m
    max log size = 50
    hosts allow = 192.168.1.0/255.255.255.0

    [homes]
    comment = Home Directories
    read only = No

    [netlogon]
    comment = Network Logon Service
    path = /usr/local/samba/lib/netlogon
    guest ok = Yes

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    [test]
    comment = This is a test system only
    path = /usr/local/samba/tmp
    read only = No
    guest ok = Yes

    [dev_modilla]
    comment = Slackware Test site
    path = /var/www/web
    read only = No
    guest ok = Yes

  4. #4
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    I am not to sure about your origional post but I think you are saying that you have a windows and samba box then a router and then another windows box and they are all 192.168.blah.blah

    If this is the case you can do some tricky stuff in smb.conf to get it to work, but I think you are assuming that since they are all 192.168 that it is all the same network and that is not true. If you have a router that dhcps to to boxes and another router that dhcps even though they both use 192.168 addresses and the subnet masks are 255.255.255.0 they are still on two networks.
    take out the second router.

    If I took what you said on your original post out of context, disregard this post


    Mike

  5. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    3

    Working Now

    Got it working.

    Basically (I think) I turned off the Windoz firewall.
    I then commeted out the
    # hosts allow = 192.168.1.0/255.255.255.0
    I connected and all is working now.

    I thought I had a handle on Samba and a little home networks. I guess I need to keep reading.
    I really think the Windows Security Firewall was the issue.

    If anyone has a good tutorial or maybe a smb.conf that they would like to share, I'll study up somemore..

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •