Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux User
    Join Date
    Mar 2008

    Get sound from PC Speaker

    Sorry for the belated response.
    I tried ls ~.Xterm and ~.Xresources they don't exist as I expected.
    I tried xset but there was no sound.
    xrdb -query yields:
    Xcursor.size: 20
    Xcursor.theme: redglass
    Xcursor.theme_core: true
    Xft.antialias: -1
    Xft.hinting: -1
    Xft.hintstyle: hintnone
    Xft.rgba: none

    xlsclients yielded:
    solar xfce4-session
    solar xfsettingsd
    solar xfwm4
    solar Thunar
    solar xfdesktop
    solar xfce4-settings-helper
    solar xfce4-panel
    solar xfce4-power-manager
    solar xfce4-menu-plugin
    solar Terminal
    solar firefox-bin
    solar '<unknown>'

    When i tried CTRL+middle button in "TERMINAL" window I get no response whatsoever.

    I tried in TERMINAL to click on Edit>Preferences to the the 5 tabs but none provide a means to care for the speaker (BTW ALSA PC speaker is NOT muted).
    I recall when I setup terminals for color background and such there was much more to the setup than in any thing I have recently tried. Perhaps someone can re giggle my gray cells as to what that might have been? I did try XFCE Menu>Terminal and XVCE Menu>Settings> ...

  2. #12
    Just Joined!
    Join Date
    May 2009
    A toughie, hey?

    Well in my window manager (GNU step), I activate a terminal -- then I have to click on the title bar to make the window active; once it is active the menus appear when I hold the ctrl button down and click on my middle or right button -- but not the normally used for everything left button.

    If it still doesn't work even with the window activated, then I can only assume your window manager is somehow blocking the clicks (absorbing the events, and not sharing...) because it wants them for a different purpose. Try holding the ctrl button down, and then press and hold the middle or right button for a full two seconds -- just to make sure your system isn't just slow, and the menus aren't drawn before you give up and let go -- so that they never get drawn.

    There is one other way to look at your resources, but it is finiky.
    From a command line you can type "editres"; if you installed X fully, it will be there. That's the standard X windows resource editor (That most people don't even know exists...). There will be two ugly buttons at the top called commands and tree. Go to the Commands menu (left click and HOLD) the menus are NOT persistent. Let go of the button on "Get Tree"; it will then tell you to go click on something.... you move the pointer over the text area of an xterm and left click -- magically a little drawing will appear with boxes and lines that says "Xterm" in the root (left box).
    You can click on say, XTerm with the left button and it will turn black -- or you can click with the right button and the first two letters will change the case from lower to upper; don't worry about the case for now -- just leave it as it comes up; so only left click on the box.

    Now if you go to the commands menu again, the "Show Resource Box" will be usable. But if you darken more than one of those boxes down below -- it won't be usable. The things to the right are different modes of xterm, so modifying them doesn't change the other -- eg: the color of vt100 won't affect shellext, etc.
    However, Xterm is a "root", and if you poison the root -- you poison the whole tree; so if you cure the root....?

    In any event, with the show resource box up -- you can left click on one of the resources listed, and it will be selected; Middle click on the same resource and at the bottom of the screen its value *now* will appear in an editable box. This is editing the resources real-time, so when you change a resource the specific xterm you are monitoring "can" in fact change but doesn't have to. One of the easiest resource is "background" which is the background color of your xterm. If no one more powerful has actually programmed vt100 to have a different color; changing background for xterm will change the color real time.
    Caviats, resedit is a little buggy and has unusual conventions. DO NOT press enter when typing in a resource -- because the next time you look at the resource you will see an empty line; hitting backspace can delete an extra enter and is recommended to check that a blank line means no value is set.
    Use the "apply" button at the bottom of the resource to make the change happen. Sometimes, I don't know why -- two resources of the same name will appear when you have edited the lowlevel xterm. Once that happens, I usually exit X11 and restart it.

    Now if "xterm" is the xterm you are working on, "XTerm" is all the xterm like objects universally. So you can poison them all if you like, or ...
    Experiment with it; as the changes are not permanently saved anywhere; and if it really gets messy -- exit X windows, and restart it.

    Once you figure out the resources you want, you can tell editres to save them to a file (you name it); and then you can create your ~/.XTerm personal settings to match it, or do whatever you want with the settings.

    In any event, you can start with those suggestions; I'm too busy to look at the other comments in detail right now -- but perhaps in a few days I will.
    Good luck, let us all know if you get any closer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts