Find the answer to your Linux question:
Results 1 to 4 of 4
Flash sometimes hogs the CPU when I play video with it on Youtube. Roughly half of the time when the player is started, it doesn't use an excessive amount of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jul 2007
    Posts
    111

    Flash CPU hog


    Flash sometimes hogs the CPU when I play video with it on Youtube. Roughly half of the time when the player is started, it doesn't use an excessive amount of CPU, however sometimes when the player is started, it will hog the CPU to such an extent that even the mouse cursor lags -- for the duration of the video being played.

    My system is 32-bit Slackware 13.1.0 on a fast x86 (Core i7, 4 GHz, 6 GiB RAM, GTX480).
    I have tried to upgrade the version of flash on my system.
    I have tried to upgrade Firefox.
    I have tried to upgrade the NVIDIA graphics drivers.

    I have this issue on another fast x86 as well, which is running 64-bit Slackware 13.1.0.

  2. #2
    Just Joined! zabalex's Avatar
    Join Date
    Sep 2011
    Posts
    6
    Hello Corge,
    I noticed, and not with one example but at least on several ocasions that flash (swf) file behaves differently on windows and linux.
    Text of the flash site is not interpreted correctly, and if tested on windows, file works well, but in linux, I can't even see the text.
    I don't know if those things are related or not, possibly just the way linux treats flash.

    Does anyone have any idea? I would like to know why?

    Here's example of the file hosted on Linux:
    Attachment 3813

    Here's what it looks like when I host it on windows:
    Attachment 3814

  3. #3
    Just Joined! zabalex's Avatar
    Join Date
    Sep 2011
    Posts
    6
    I just found a solution to my own question.
    If Windows hosting is used and the flash is loading the content from an external file, such as XML, the '\n' is interpreted differently.
    On Windows, the following lines work correctly:

    <link systemOrder="2"><![CDATA[
    ABOUT US
    ]]></link>

    The above did not work on Linux, but if I change to:

    <link systemOrder="2"><![CDATA[ABOUT US
    ]]></link>

    Now it works great.

    On Windows

  4. #4
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    I have the same issue on Slackware 13.1 and 13.37. But it only happens if i leave my comp for a couple of hours and bring it back from snoozing
    I have to restart firefox to get it to work normally. Most of the times the the clip (video) is running normally, but the sound is really messed up.
    I guess it's linux/flash(sound) issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •