Find the answer to your Linux question:
Results 1 to 5 of 5
Hello. I installed Slackware 13.37, everything ok. Now I try run a program but I cant. I already tried search on google/other sites but didn't find nothing. An example: bash-4.1# ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2011
    Posts
    1

    Problem with Slackware 13.37


    Hello.

    I installed Slackware 13.37, everything ok. Now I try run a program but I cant. I already tried search on google/other sites but didn't find nothing.

    An example:
    bash-4.1# mplayer
    bash: /usr/bin/mplayer: No such file or directory

    This occurs with ALL programs that I tried to install. Slapt-get, gslapt, google chrome, mplayer and etc.

    When I try locate the program:
    bash-4.1# locate mplayer
    /usr/bin/mplayer

    And i already tried use which and file

    bash-4.1# which mplayer
    /usr/bin/mplayer
    bash-4.1# file /usr/bin/mplayer
    /usr/bin/mplayer: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), stripped

    and no matter what I do, I always get:

    bash-4.1# mplayer
    bash: /usr/bin/mplayer: No such file or directory

    I'm using KDE. This happen with ALL programs that I tried to install...

    Anyone know what to do?

    Thanks in advance!

  2. #2
    Just Joined!
    Join Date
    Jul 2010
    Posts
    2
    well have u try install another program with slackpkg tool
    and i assume that program has been installed but not running

  3. #3
    Just Joined! ford's Avatar
    Join Date
    Jan 2011
    Location
    GA, USA
    Posts
    25
    Have you tried using slackpkg to update, and then install through SlackBuilds?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    Did you try to install them with root? If that goes OK, maybe you should check your user permissions.
    Also, try running them with the absolute past e.g. /usr/sbin/mplayer
    One more thing - are you running X?

  6. #5
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Is it a 64-bit vs 32-bit problem? Try using ldd tool to show the libraries required by a binary:
    Code:
    ldd /usr/bin/mplayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •