Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
I am using Slack 10 and KDE. Under services its says the KDE print deamon is running but I thing that is something different. I dont see anywhere that allows ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Nov 2004
    Posts
    25

    I am using Slack 10 and KDE. Under services its says the KDE print deamon is running but I thing that is something different. I dont see anywhere that allows me to click a checkbox to let cups startup also I have to be root to start cups, Thats seems a little strange. ?

  2. #12
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    The steps I descriibed using the graphical interface we're for use with Gnome, not KDE.
    To be honest, I don't know where it's located in KDE.
    Slackware works a bit different than RedHat/Fedora.

    Most daemons that are booting run with root permission, some who use other usernames/groupnames, run in a ' jail' . This gives your system some extra security should that daemon have a 'bug' in it, harmfull persons cannot use it to exploit it to gain root access to your system.

    I find it strange that cups doesn't start.
    You are sure that CUPS is installed ? Use the pkgtool to check that.
    if you type: ps -ef | grep cup
    What is it's output ?
    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  3. #13
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    K>settings>printing manager>
    Lower right there is a dropdown menu - if it says lprng or anything other than cups change it to cups

    Mike

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Nov 2004
    Posts
    25
    Yes its installed and I just downloaded and installed it again. I have always had cups set under the print manager settings. I do get an output with ps -ef | grep cup but cannot cut and paste it here. I can start up cups manually by going superuser and cd /etc/rc.d then ./rc.cups start. Then I can print, Thats what I do whenever I want to print something. If you have any more ideas let me know, thanks.

  6. #15
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Quote Originally Posted by Hammer
    Yes its installed and I just downloaded and installed it again. I have always had cups set under the print manager settings. I do get an output with ps -ef | grep cup but cannot cut and paste it here. I can start up cups manually by going superuser and cd /etc/rc.d then ./rc.cups start. Then I can print, Thats what I do whenever I want to print something. If you have any more ideas let me know, thanks.
    I think you can put /etc/rc.d/rc.cups start in your rc.local file and it will work not sure if it is the right way but I think it will work.

    Mike

  7. #16
    Just Joined!
    Join Date
    Nov 2004
    Posts
    25
    That does not work because no matter where I put it It, CUPS needs root access to start. I have tried changeing permissions of rc.cups and of rc.d and it does not stick.

  8. #17
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    I thought if you put it in rc.local you had to be root to write to it and therefore would run root apps. I will look and see if I can dig something up, but I run slack 10 and I don;'t have that problem so maybe you have something wierd with your set-up.

    That being said i know that slack likes lprng and that conflicts with cups try turning off or uninstalling lprng and see if that helps.

    Mike
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  9. #18
    Just Joined!
    Join Date
    Nov 2004
    Posts
    25
    Cool, thanks. I dont mind much having to start cups manually so dont spend to much time on it, But thanks for all the help. Ill play around with it once in a while and maybe I will get it. Thanks again.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •