Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    How do I get cups to start at boot?


    How do I get cups to start at boot or when my default user logs on?
    This is from my /etc/rc.d/rc.M file and it looks like its already set.

    # Start the print spooling system. This will usually be LPRng (lpd) or CUPS.
    if [ -x /etc/rc.d/rc.cups ]; then
    # Start CUPS:
    /etc/rc.d/rc.cups start
    elif [ -x /etc/rc.d/rc.lprng ]; then
    # Start LPRng (lpd):
    . /etc/rc.d/rc.lprng start
    fi

    Thanks for any help.

  2. #2
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    chmod +x /etc/rc.d/rc.cups

  3. #3
    Thanks.

  4. $spacer_open
    $spacer_close
  5. #4
    OOPS! That didnt work. Where is it that I place that?

  6. #5
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    command line

    su -
    passwd

    cd
    cd /etc/rc.d
    chmod +x rc.cups

    Let me know

    Mike

  7. #6
    Thats not working Thats exactly what I did like 3 times the other day and just now I tried it again exactly how you typed it, Rebooted and cups is still not starting up. Is there another way?
    If i do
    cd /etc/rc.d
    ./rc.cups
    I can start it up manually but I dont want to do that every time I want to print something.
    Thanks for the help.

  8. #7
    try sysVinit and try adding it in early runlevels

  9. #8
    Where is sysVinit? I know, I should know that. LOL

  10. #9
    Does hotplug need to be running or started at boot for the cups daemon to start?

  11. #10
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    Quote Originally Posted by Hammer
    Does hotplug need to be running or started at boot for the cups daemon to start?
    No, it doesn't . hotplug is used to monitor if you plug in any USB devices or other pcmcia cards.

    What distro are you using ?

    To enable cups using your graphical interface (gnome)
    to go->System Settings-> Server Settings->Services
    and turn it on there.
    Be sure you check it on both runlevel 3 as 5.

    If you use the terminal type use: chkconfig
    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •