Find the answer to your Linux question:
Results 1 to 7 of 7
Last night, I upgraded my Slackware box from Dropline GNOME 2.6.2 to 2.8. I followed the instructions on the Dropline webpage: installpkg dropline-installer-2.4.9-i686-1dl.tgz dropline-installer After it was done, it said ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5

    Slack 10 won't fully boot w/ Dropline GNOME 2.8


    Last night, I upgraded my Slackware box from Dropline GNOME 2.6.2 to 2.8. I followed the instructions on the Dropline webpage:

    installpkg dropline-installer-2.4.9-i686-1dl.tgz
    dropline-installer

    After it was done, it said that some changes might not take effect until I restarted, so I went ahead and restarted.

    The system then booted up to the login screen--everything looks fine there. However, when I try to log in either "root" or my personal account, it just goes to a grey screen and doesn't do anything. Doesn't load up. Just stays at the gray screen forever.

    Ideas?

    I also tried the "safe" GNOME mode, but got the same result. How do I fix this?

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    It's likely to be a problem with permissions.

    There should be a session option for logging in with a terminal or summat.

    Do that and login as root. you should get a grey screen with a terminal bottom right.

    Then change the permissions on the /tmp directory.

    chmod -R 777 /tmp

    Then reboot and all should be well.

    I think there's a recommended set of permissions but can't remember what it is.

    Alternative is to boot with a live cd like knoppix and change the permissions that way.

    Post back with the results
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5
    when logging in to "failsafe terminal"

    Your session only lasted less than 10 seconds. If you have not logged out yourself, that could mean that there is some installation problem or that you may be out of diskspace. Try logging in with one of the failsafe sessions to see if you can fix the problem.

    The ~/xsession-errors file says:

    /etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
    /etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg - a -w /var/log/wtmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "root"
    xterm: Error 14, erno 21: Is a directory
    Reason: spawn: open() failed on /dev/tty

    What does this mean?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5
    OK, I cannot seem to change permissions using Knoppix--it won't let me edit permissions under Properties when I use Konqueror.

    Alternate Suggestions?

  6. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Open a terminal in knoppix and type su -

    This will allow you to change the permissions from within that terminal.

    So then type

    chmod 777 /tmp

    Then all should load when you login to Dropline.

    Post back if probs
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  7. #6
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5
    Thanks for the suggestion but same result.

    Weird thing is I can boot into KDE but just not GNOME. I tried recompiling my kernel; I tried reinstalling GNOME. Something's going on here. Does the readout of my ~/xsession-errors file yield any clues?

  8. #7
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5
    Found the problem. GNOME wanted the oss-mixer module. Recompiled kernel w/ that module in, and it works nicely now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •