Find the answer to your Linux question:
Results 1 to 6 of 6
Hi Slackers; I recently installed Slackware 13.37 and I'm still working to configure it. At this point when I log in as a standard user I'm not able to access ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2011
    Location
    Tijuana
    Posts
    2

    Unable to access USB devices when I log in as a standard user (Solved)


    Hi Slackers; I recently installed Slackware 13.37 and I'm still working to configure it.
    At this point when I log in as a standard user I'm not able to access USB devices, let's say, if I connect my USB hard drive I get the next message: "Could not mount following device: FreeAgent GoFlex Drive"; however when I log in as a root I can access this USB hard drive and any other USB device. Has anybody experienced this problem?

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Has anybody experienced this problem?
    It's not a "problem". You need to be root to mount partitions/filesystems and you need to have an entry for your partitions on external drives in the /etc/fstab file to give users access or read or write or both.

    You could post the contents of your fstab file and the output of fdisk -l(lower case letter L in the command) with your partition information and specifics on what you are trying to access.

  3. #3
    Just Joined!
    Join Date
    May 2009
    Location
    Oregon
    Posts
    51
    What you are likely wanting to do is modify your /etc/fstab so that non-root users can mount drives.
    Slackware has a common mounting point called /media that is often useful for this type of non-root mounting of drives.
    In my own fstab, for example, I have this line included:

    Code:
    /dev/sdb	 /media/memory	  auto	      noauto,users,rw,sync,exec 0 0
    /dev/sdb1	 /media/memory1	  auto	      noauto,users,rw,sync,exec 0 0
    /dev/sdb2	 /media/memory2	  auto	      noauto,users,rw,sync,exec 0 0
    When I plug in a USB stick, on my base system, the first sick is called sdb, then the partitions on that stick (regardless of filesystem) are called sdb1, sdb2, ...
    The above lines are set up to allow regual "users", not just super-user, to mount a memory stick's partition on /media/memory (if it isn't partitioned, but is a single file-system),
    or if multiple partitions, /media/memory1, media/memory2, etc...

    If these directories don't exist, just do a: mkdir /media/memory1
    for each of them as super user, and they will be created.


    As a normal user, I can type in: mount /media/memory1
    and the first partition on my memory stick will show up on that directory, and be read-writeable by a normal user.

    I suggest you google around, or read the manual pages on fstab, to learn what all the options mean; and what you may/may not do.

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by andrewr View Post

    I suggest you google around, or read the manual pages on fstab, to learn what all the options mean; and what you may/may not do.
    You might also find the man pages for "mount" command to be very helpful also. Just in case you don't know how, open a terminal/konsole window and type
    man {command name}
    without the brackets of course.
    So man pages for mount command would be
    Code:
    man mount
    For fstab
    Code:
    man fstab
    Most system commands will provide a man page entry when they are installed.
    without the brackets of course.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #5
    Just Joined!
    Join Date
    Nov 2011
    Location
    Tijuana
    Posts
    2
    Hello everyone, thank you for your replies.
    I found a link that explains how to enable non-root user to mount usb devices, basically I followed 2 steps:
    1) I have modified 4 lines in the file /etc/group:
    wheel : x:10:root,rafael
    audio : x:17:rafael
    cdrom : x:19:rafael
    plugdev : x:83:rafel
    2) Edit the file /etc/login.defs
    CONSOLE_GROUPS floppy:audio:cdrom:scannerlugdev

    Once this was done I was able to mount my external USB devices (USB hard drive and memory sticks).

    Thanks a lot

    EDIT:http://brionetka.com/linux/?p=127
    Last edited by MikeTbob; 11-22-2011 at 05:14 AM. Reason: Added Link

  7. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Thanks for posting your solution, it may help others with the same or similar problem. *marking as Solved and closed*
    If you'd like to send me the link that you mentioned via private message I'll add it to your thread for you, for completeness.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •