Find the answer to your Linux question:
Results 1 to 2 of 2
If you are unable to get sound working in Slackware, this guide may provide a solution to the problem. You will need to be root in order to make the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471

    A solution for no sound in Slackware 13.37


    If you are unable to get sound working in Slackware, this guide may provide a solution to the problem.

    You will need to be root in order to make the following changes:

    In order to get ALSA to detect and configure the card we must first run 'alsaconf'. Alsaconf has a database of cards in order to identify given hardware, but some hardware may not exist in this database, resulting in the following message:



    In order to get alsaconf to see our card, we must first add it to the card database. After alsaconf has been run you will find /var/tmp/alsaconf.cards has been created, and this file contains the list of cards it can detect.

    To find out some information about the card we must run 'lspci -nn' and search through to find the card:

    Code:
    00:1b.0 Audio device [0403]: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller [8086:3a3e]
    The important bit to note is the bit at the end: 8086:3a3e. This is what we will now add to /var/tmp/alsaconf.cards. First the appropriate location must be found, and in this case we want to put it under snd-hda-intel.o:

    Code:
    snd-hda-intel.o
    PCI: 0x8086=0x3a3e
    You should be able to find out where to put it by running 'lsmod' and finding the name of the loaded sound module for your card.

    Once this is added in, rerun 'alsaconf' and the card should now be discovered:



    Run through the process and let it modify /etc/modprobe.d/sound.conf, and the sound card should now be configured. The levels can be set through 'alsamixer'

    ------------------------------------------------------

    Device ordering:

    On my system I have a USB webcam with a built in microphone, and because this is loaded first it shows up as the primary device.



    This can cause problems, such as when playing videos in Firefox the following message may appear:

    Code:
    ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
    The solution is to modify the order in which the devices are loaded by modprobe, and we need to go back to /etc/modprobe.d/sound.conf. After adding
    Code:
    options snd_hda_intel index=0
    options snd_usb_audio index=1
    to the beginning of the file and rebooting the machine, snd_hda_intel is loaded first and becomes the primary device:



    The sound should now be fully working.

  2. #2
    Just Joined!
    Join Date
    Jan 2014
    Posts
    1
    Sound vanished in my 13.37 installation. Each time I corrected the problem in alsamixer which read "This sound device does not have any playback controls," alsamixer lost its playback controls despite # alsactl store entered. The problem was a USB webcam which had a microphone and was preventing the right sound modules from being loaded. Disconnecting the webcam solved the problem. This was hard to find.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •