Find the answer to your Linux question:
Results 1 to 7 of 7
I have installed slackware 13.37 and can't get my network card or Wireless card to work. I tried using netconfig to statically assign an IP address to my LAN. The ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2011
    Posts
    11

    Network setup problems


    I have installed slackware 13.37 and can't get my network card or Wireless card to work. I tried using netconfig to statically assign an IP address to my LAN. The IP address shows when i do a ifconfig but I can't ping anything?

    Below are the devices I have:

    Intel Corp Pro/Wireless 2200BG (Calexico2) Network Connect

    Broadcom Corp Netxtreme BCM5751 Gigabit Ethernet PCI Express.

    I am brand new to linux and setting this up to do Forensic Investigations. I would greatly appreciate any help or advice to get my network running.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Have you verified the TCP/IP settings by looking in the files themselves? See here for a good description.

    Show the state of your devices:
    Code:
    ip a
    Show your routing table:
    Code:
    route -n
    Show your DNS settings:
    Code:
    cat /etc/resolv.conf
    Make sure your ethN device has a physical connection:
    Code:
    ethtool ethN|grep Link
    Finally, what exactly are you trying to ping? Show what you're trying and what you get.

  3. #3
    Just Joined!
    Join Date
    Nov 2011
    Posts
    11
    Okay I ran the above commands and this is what I get:

    Code:
    root@shrfforensics:/home/tg3-3.118k# ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
        link/ether 00:13:ce:11:52:32 brd ff:ff:ff:ff:ff:ff
        inet 10.24.48.241/8 brd 10.255.255.255 scope global eth0
        inet 169.254.18.39/16 brd 169.254.255.255 scope global eth0
        inet6 fe80::213:ceff:fe11:5232/64 scope link 
           valid_lft forever preferred_lft forever
    3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
        link/ether 00:11:43:7a:0d:8b brd ff:ff:ff:ff:ff:ff
    root@shrfforensics:/home/tg3-3.118k# route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    169.254.0.0     0.0.0.0         255.255.0.0     U     302    0        0 eth0
    10.0.0.0        0.0.0.0         255.0.0.0       U     0      0        0 eth0
    127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
    root@shrfforensics:/home/tg3-3.118k# cat /etc/resolv.conf
    search glynncounty-ga.gov
    nameserver 10.24.1.5
    root@shrfforensics:/home/tg3-3.118k# ethtool eth0 | grep Link
            Link detected: no
    root@shrfforensics:/home/tg3-3.118k# root@shrfforensics:/home/tg3-3.118k# 
    root@shrfforensics:/home/tg3-3.118k# root@shrfforensics:/home/tg3-3.118k# ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
        link/ether 00:13:ce:11:52:32 brd ff:ff:ff:ff:ff:ff
        inet 10.24.48.241/8 brd 10.255.255.255 scope global eth0
        inet 169.254.18.39/16 brd 169.254.255.255 scope global eth0
        inet6 fe80::213:ceff:fe11:5232/64 scope link 
           valid_lft forever preferred_lft forever
    3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
        link/ether 00:11:43:7a:0d:8b brd ff:ff:ff:ff:ff:ff
    root@shrfforensics:/home/tg3-3.118k# route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    169.254.0.0     0.0.0.0         255.255.0.0     U     302    0        0 eth0
    10.0.0.0        0.0.0.0         255.0.0.0       U     0      0        0 eth0
    127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
    root@shrfforensics:/home/tg3-3.118k# cat /etc/resolv.conf
    search glynncounty-ga.gov
    nameserver 10.24.1.5
    root@shrfforensics:/home/tg3-3.118k# ethtool eth0 | grep Link
            Link detected: no
    root@shrfforensics:/home/tg3-3.118k#
    I am a little confused why the Link detected is no: I have lights on the laptop network card and the switch that I am plugged into.
    I also download the driver for my card and as far as I know it is installed.

    The only thing I can ping is the static address I assigned the card 10.24.48.241 Anything else like 10.24.1.5 I get host unreachable.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2011
    Posts
    11
    one thing I forgot to mention.

    Dmesg is shutoff
    HAL is shutoff

    that way i don't accidentally mount a drive.

  6. #5
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    What do you mean by 'dmesg is shutoff'? That won't automount anything, it just reports kernel messages.

    What is weird about your eth0 is that it looks like it is trying to acquire a DHCP address (69.254.18.39) even though you have a static one assigned. Can you post the contents of your network config files? Hopefully a slackware weenie here can verify them.

    It is odd that there is no Link detected for eth0, assuming it is your wired/Broadcom connection. Is the RJ45 on either end of the CAT5 cabled shoved into the respective ports securely on both ends?

    Run these commands so we can see what device is what:

    Code:
    lspci
    ethtool -i eth0
    ethtool -i eth1
    Also run this, to check on wireless capabilities:
    Code:
    iwconfig
    Are you trying to set up the wireless adapter as well? If so, do you have a known access point/router that you are trying to connect to? Is there a router on your network that you should be using as a gateway/default router?

    For your wired connection, are you supposed to be using static ip assignment, or are you supposed to be getting IP info from a DHCP server?

    Are you trying to get out onto the internet via the wired? If using wireless, what about that?

    Not sure about your ping command that you specified, maybe it is a netmask issue. But first, you need to figure out why you do not have a physical link detected.

    Once you do have a physical link on your wired connection, try this command to do a scan of your local network, assuming eth0 is wired and has the ip address of 10.24.48.241/8:
    Code:
    nmap -n -sP 10.24.48.0/8
    Edit: only run that nmap command if you have full reign over your local network, otherwise you might piss off some admins...
    Last edited by atreyu; 11-23-2011 at 04:24 PM. Reason: nmap

  7. #6
    Just Joined!
    Join Date
    Nov 2011
    Posts
    11
    well I blew away the computer reinstalled slackware to make sure i Didn't set anything unusual. I have been able to connect to wireless and hardwire now.

    I do appreciate the help the links that were posted helped me greatly. This is going to be a great adventure learning to use linux (slackware).

    As far as dmesg and hald being turned off that was recommened from linuxleo.org Linux LEO manual. I was under the impression it was due to automounting hardware that is attached which ofcourse is bad from a forensic standpoint.

    Thanks again for all the help.

  8. #7
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by ptyo View Post
    well I blew away the computer reinstalled slackware to make sure i Didn't set anything unusual. I have been able to connect to wireless and hardwire now.
    Great! Sometimes it is better to start from scratch.

    As far as dmesg and hald being turned off that was recommened from linuxleo.org Linux LEO manual. I was under the impression it was due to automounting hardware that is attached which ofcourse is bad from a forensic standpoint.
    Understood. Just understand that they are wrong (as far as I know) on the dmesg part. That tool is invaluable in trouble-shooting kernel-related problems. And anyway, I don't even know *how* to turn it off.

    good luck w/Slackware!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •