Find the answer to your Linux question:
Results 1 to 5 of 5
I just installed Slack 10 on my laptop, it's dualboted with XP. I think I screwed up the bootloader (I thought I installed LILO) because whenever I turn on the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    166

    Bootloader Trouble


    I just installed Slack 10 on my laptop, it's dualboted with XP. I think I screwed up the bootloader (I thought I installed LILO) because whenever I turn on the computer, I'm presented with a grub> prompt. How can I boot into windows or linux (preferrably both)? I don't think I'm that screwed, but it's got me worrying...
    Registered Linux User Number 373366

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Oklahoma City, OK
    Posts
    232
    It sounds like you've had RedHat/Fedora, SUSE or another distro that uses GRUB as a boot loader installed on that system previously. Also, I'd bet you installed LILO to Slackware's default location, the superblock of your / partition.
    Installing LILO to / isn't a problem but you'll need to set that partition as the bootable partition. To do this, just boot from your Slackware installation cd and, once you're at the root prompt(#), run cfdisk and change the boot flag from /dev/hda1 to your / partition.
    You could also change the location of LILO to the MBR. I'll explain that later if needed.
    OH NOOOOO!!!!!! You did it the way I said?

  3. #3
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    166
    well, I did what you said, and I still get a grub prompt. What can I do to be able to get LILO to load and have it let me boot inot either Slack or Windows???
    Registered Linux User Number 373366

  4. #4
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Oklahoma City, OK
    Posts
    232
    First, you need to boot in to the installed system. To do that, pop in cd1 and at the boot prompt enter
    Code:
    boot: bare.i root=/dev/hda1 noinitrd ro
    Of course, change /dev/hda1 to suit your installation.
    Once the system is booted and you're logged in to the root account, run liloconfig to re-install lilo. This time, instead of accepting the default install location, choose MBR. Everything else is answering the questions as they're asked.
    OH NOOOOO!!!!!! You did it the way I said?

  5. #5
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    166
    WORKS GREAT!!! Thanks so much u-turn! I thought about installing to the MBR during origional install, but I didn't want ot loose Windows just yet, and it said "possibly unsafe" so I went with the default...but it's fixed now!!!
    Registered Linux User Number 373366

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •