Find the answer to your Linux question:
Results 1 to 9 of 9
Alright, I have been searching for 2 days for an answer on this, but haven't yet found one. Recently, I was using PartitionMagic 8.0 to change the size of one ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2

    partition troubles


    Alright, I have been searching for 2 days for an answer on this, but haven't yet found one. Recently, I was using PartitionMagic 8.0 to change the size of one of my partitions, I then used parted to resize my reiserfs partition to slightly larger because I had stupidly created it too small. When I went to restart, apparently my partitions got totally messed up and I cannot boot windows anymore.

    I am currently running Slackware 9.1. I can mount my windows NTFS partition via linux, and it can find, read, and use all the files on there just fine, so I know all the data is still there, but I'm trying to get this sorted out without having to reformat. Here is some other various info:

    output of fdisk -l

    Code:
    root@cheese:/home/jeremy# fdisk -l
    
    Disk /dev/hda: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1               1         583     4682443+   b  W95 FAT32
    Partition 1 does not end on cylinder boundary.
    /dev/hda2   *         583       15622   120802185    7  HPFS/NTFS
    Partition 2 does not end on cylinder boundary.
    /dev/hda3           15622       16807     9521347+  83  Linux

    and of sfdisk

    Code:
    root@cheese:/home/jeremy# sfdisk -V -l /dev/hda
    
    Disk /dev/hda: 19457 cylinders, 255 heads, 63 sectors/track
    Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0
    
       Device Boot Start     End   #cyls    #blocks   Id  System
    /dev/hda1          0+    582-    583-   4682443+   b  W95 FAT32
                    end: (c,h,s) expected (582,239,63) found (990,149,63)
    /dev/hda2   *    582+  15621-  15040- 120802185    7  HPFS/NTFS
                    start: (c,h,s) expected (582,150,1) found (990,60,1)
                    end: (c,h,s) expected (1023,254,63) found (1023,149,63)
    /dev/hda3      15621+  16806    1186-   9521347+  83  Linux
    /dev/hda4          0       -       0          0    0  Empty
    Warning: partitions 1 and 2 overlap
    /dev/hda1 is the recovery partition that ships with the computer
    /dev/hda2 is the windows partition
    /dev/hda3 is my linux partition

    I have completely run out of ideas, so I'm hoping maybe someone here can help me.

    Also, I have a windows XP install CD, and was able to get to the
    recovery console fine, it saw that install and partition, I ran cfdisk, fixboot, and fixmbr, and nothing worked there....

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Oklahoma City, OK
    Posts
    232
    OK. First, this isn't a Slackware problem. It's a Windows problem.
    Second, the problem is clearly stated in your sfdisk printout.
    Code:
    Warning: partitions 1 and 2 overlap
    This can't happen.
    I can't help you any further due to the fact that I don't use Windows and am not familiar with partition tools written for it. I suggest you find a Windows support forum. You'll be more likely to find the answer.
    OH NOOOOO!!!!!! You did it the way I said?

  3. #3
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    partition 1 and 2 overlap is mainly caused by multi FS type, 512b other are 1024b... so your problem is probly only this..

    you can try a later version of partition magic and boot from recovery disk, and from there try applying the partition table once more...
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2
    Well, this was originally a linux problem caused by using parted in conjunction with partition magic, bad idea. I fixed it by diiging through the HD one sector at a time and looking for the superblocks then rewriting it via sfdisk.

    And I knew the problem, I was looking for how to fix it, and I clearly said that I could not boot windows, and was running slackware, which is why I assumed this would be the place to get help for it, windows tools will do me no good since I can't boot into windows, I was looking for help via linux, but I got the partitions straightened out, now i'm just down to windows booting errors, which I'm trying to fix

  6. #5
    rjd
    rjd is offline
    Just Joined!
    Join Date
    Jan 2005
    Location
    Northeast USA
    Posts
    8

    "parted" has been accused of hideous crimes

    After installing Suse 9.1. I had problems similar to what Pickleman78 describes. In http://forums.suselinuxsupport.de I found a posting that says partially:
    -----------------------------------------
    Symptom
    ...the Linux system can be booted, but the Windows system no longer boots. ...

    The problem cannot be solved by ...writing a new MBR with Windows tools (with the command FIXMBR or with FIXBOOT from the Windows rescue console). Repairing the partition table with proprietary partitioning tools does not solve the problem and may even destroy the entire partition table. The problem cannot even be solved by uninstalling Linux or reinstalling Windows without deleting the entire hard disk.

    Cause
    The partitioning tool parted,...may write an incorrect partition table. The problem occurs if
    the BIOS and Linux "see" different disk geometries AND
    the Windows partition is larger than about 8 GB (more precisely: if the first hard disk partition ends on cylinder 1024 or beyond this point).
    ...Currently, this problem also occurs on other Linux distributions using kernel 2.6.
    ----------------------------------------

    I don't know what "deleting the entire hard disk" means. I've tried to install 9.1 twice. After the first time, I had to use the Western Digital diagnostice to write 0's on the disk before I could reinstall Windows.

    I am writing this on Windows XP, booted from a floppy. (Booting from the hard disk produces "NTLDR is missing".)

    I've asked suse whether their 9.2 can get around this problem.

    Despite what the post in suselinuxsupport says, does anyone know whether the partition info can be repaired without "deleting the entire hard disk"? Is there a tool that can force partition info?

  7. #6
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    Any tool you will use to fix this has the risk of destoying your data. As long as you can access your data try to make a backup (you could buy a harddisk, you will need it in time anyway and they are cheap now..) Or make a backup of the most important data on cd/dvd's .
    Sorry to say but these messages are bad news. And I don't think there will be a 100% safe solution without a backup.
    I\'m so tired .....
    #200472

  8. #7
    rjd
    rjd is offline
    Just Joined!
    Join Date
    Jan 2005
    Location
    Northeast USA
    Posts
    8
    Despite searching, I missed the posting in "Redhat / Fedora Linux Help", "FC3 vs. FC2 on messing up duel-boots & WinXP?". The reply from jens 05 Dec 2004 11:37 pm points to http://lwn.net/Articles/86835/

    That article discusses using fdisk, but is there a Windows tool that is as useful?

    (I think Norton Ghost's recovery utilities can edit the partition table.)

  9. #8
    rjd
    rjd is offline
    Just Joined!
    Join Date
    Jan 2005
    Location
    Northeast USA
    Posts
    8
    Puntmut's warning and advice are on the mark, except that restoring with Norton Ghost didn't work for me. It's time to find a disk image preserver that knows nothing about MBR's, partitions, and operating systems.

    Anyhow...

    After googling frantically, and reading postings from all over the planet, I noticed that Ghost, BCM Diagnostics, and DiskInvestigator said my disk has 240 heads, but the MBR said 255. After fuming for a couple of hours, I screwed up the necessary courage and changed the MBR with Ghost, and now the machine boots to Windows just fine. Of course the Linux partitions are useless, the Suse manuals and CDs are in their box, and the box is serving as a doorstop.

    Does anyone know a Linux vendor who actually tests their product before unleashing it on the citizenry?

  10. #9
    Just Joined!
    Join Date
    Nov 2004
    Location
    Pacific North West
    Posts
    31
    Although SuSE is one of my favorite distros, I'd recommend the Xandros for its simplicity as it offers a smooth transition from Windows to Linux. You can download the free Open Circulation Edition from their web site.

    http://www.xandros.com/products/home..._oc_intro.html

    Good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •