Hi All,

Last week I upgraded to Slackware 13.37 and I am now working
on cleaning up the aftermath. One casualty has been
ImageMagick's convert command which I use often in scripts.
I installed ImageMagick from Slackware package

imagemagick-6.6.6_10-i486-1.

When I execute the convert command it fails with error:

convert: Wrong JPEG library version: library is 62, caller expects
80 `/home/neil/image.jpg' <at> error/jpeg.c/EmitMessage/235.

(<at> is the 'at' sign. I don't have enough linuxforum posts
to use the circle a thingy.)

It turns out there are two libjpeg versions in Slackware 13.37
/usr/lib. Here is a partial listing:

-rw-r--r-- 1 root root 165260 Dec 11 2006 libjpeg.a
-rwxr-xr-x 1 root root 914 Apr 4 2010 libjpeg.la*
lrwxrwxrwx 1 root root 22 Mar 15 07:34 libjpeg.so -> /usr/lib/libjpeg.so
.62*
lrwxrwxrwx 1 root root 17 Mar 15 20:36 libjpeg.so.62 -> libjpeg.so.62.0.
0*
-rwxr-xr-x 1 root root 126528 Mar 21 2011 libjpeg.so.62.0.0*
lrwxrwxrwx 1 root root 16 Mar 15 20:36 libjpeg.so.8 -> libjpeg.so.8.0.1*
-rwxr-xr-x 1 root root 216524 Mar 21 2011 libjpeg.so.8.0.1*


libjpeg.so.62.0.0 is installed by Slackware 13.37 package
aaa_elflibs-13.37-i486-7.
libjpeg.so.8.0.1 is installed by Slackware 13.37 package
libjpeg-v8a-i486-1.

When I build ImageMagick from source (ImageMagick-6.6.9-5)
configure gives

warning: libjpeg.so.8, needed by /usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libdjvulibre.so, may conflict with libjpeg.so.62

and similar warnings for libjasper, libtiff and libwmf as well
as libdjvulibre. When run, the resulting convert fails with
the same error message as above.

I tried manually removing all traces of libjpeg version 62 from
/usr/lib and /usr/include/jpeglib.h then rebuilding ImageMagick
from source (ImageMagick-6.6.9-5). ./configure warned about
libjpeg only that Ghostscript required libjpeg.so.62 which
could not be found. Compilation completed without errors but on
execution convert failed with

/usr/bin/convert: error while loading shared libraries:
libjpeg.so.62: cannot open shared object file: No such file or
directory

How is it other Slackware users and programs apparently have
no problems with these multiple libjpeg personalities? Where is
it hard coded in ImageMagick that it must have libjpeg.so.62?

Almost certainly the problem is something quite simple that I
have done or omitted to do but I don't see it. Any ideas?

Neil