Find the answer to your Linux question:
Results 1 to 10 of 10
Hello All, I have a SLACKWARe server, i want to access it from my window PC, i need to access its Graphical user interface and command line interface also. Which ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    17

    Remotely accessing a SLACKWARE server along with its GUI


    Hello All,
    I have a SLACKWARe server, i want to access it from my window PC, i need to access its Graphical user interface and command line interface also. Which software should i use on windows machine for this?

    P.S :
    I can't reach my SLACKWARe server directly, i need to reach a gateway machine and from there only, i can reach my exact SERVER.
    Is it possible that i can access the GUI of my SLACKWARE server in such scenario and which client should i use on my windows machine to access the server.
    Thanks in advance for your much valued suggestions.

  2. #2
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    I use Xming and PuTTy. If the gateway machine is running an sshd with X11Forwarding configured, you can start Xming, PuTTy to the gateway, and ssh -X to the server, and X displays will tunnel back to your Windows desktop.

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Posts
    17
    HI Mudgen,
    Thanks for the reply. If i understand correctly, i need to use either Xming or Putty, not both the softwares together. And can you please tell me how can i configure X11 forwarding on a gateway, can you share some steps?
    Thanks in advance.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Quote Originally Posted by nitesh View Post
    HI Mudgen,
    Thanks for the reply. If i understand correctly, i need to use either Xming or Putty, not both the softwares together. And can you please tell me how can i configure X11 forwarding on a gateway, can you share some steps?
    Thanks in advance.
    As I indicated, you need both for your purposes. Xming is the X server running on the Windows side, PuTTy is the ssh client.

    You configure sshd for X11 forwarding by putting "X11Forwarding yes" in its config file. That's /etc/ssh/sshd_config on RedHat/Fedora/Centos/etc. It might be somewhere else in Slackware.

  6. #5
    Just Joined!
    Join Date
    Apr 2009
    Posts
    17
    Hi mudgen,

    I am sorry to say but i did not exxactly understand the solution. I installed Xming on my windows machine, it just started as a background process, how can i use Xming to connect to my server. Can you please help me out in this? Is it possible for you to provide some more information.

  7. #6
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Yes, Xming just runs as a background process: it's the display server, not a connection agent. Now start putty, drill into the config and make sure X11 forwarding/tunneling is turned on, then use it to connect to your gateway. Any X app you run will send the display back to Xming on your machine.

    I'd suggest also reading some of the doc on Xming and putty.

  8. #7
    Just Joined!
    Join Date
    Apr 2009
    Posts
    17
    Hi,
    My requirement has changed and i have no solution, please help. Below is the description of the requirement.
    I have a SLACKWARE server, it has no external display connected to it, i can directly reach it on network from my Windows machine. I am using PUTTY to reach the SERVER. I want to run X applications on the SERVER via my windows machine, which is the best possible software for this. If i am not wrong, Putty won't support X applications. Please suggest, i am a newbie of the world of linux servers and related stuff.
    Thanks in advance.

  9. #8
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Xming running in the background, and putty as your ssh connection agent will work. Run the Xlaunch front-end to Xming, click through the defaults, and it will start an X server in background. Then run putty as I said above. When you get logged in, type "xterm" and a an X-based terminal should pop up. That's just an example X-based program.

  10. #9
    Just Joined!
    Join Date
    Apr 2009
    Posts
    17
    Thanks for your reply Mudgen, i tried it, but it did not work for me. I followed the below steps:

    ------------------------------------------------------------------------
    Configure Xming

    Click on the Start button in Windows XP, select Xming → XLaunch
    At the Display settings dialog box, select Multiple windows and set the Display number as 0. Click on Next.
    Keep clicking on Next button till you reach the Finish configuration page, then click on the Finish button.

    Configure PuTTY

    Start PuTTY.
    In the PuTTY Configuration section, on the left panel, select Connection → SSH → X11
    On the right panel, click on the Enable X11 forwarding checkbox
    Set the X display location as :0.0
    Click on Session option on the left panel.
    Enter the hostname or IP address in the Host Name textbox
    Save the session.

    Running the X applications from PuTTY

    Double-click on your PuTTY session and login. After you login, a file named .Xauthority will be created.
    Check if the DISPLAY variable has been set.

    echo $DISPLAY

    You should see a meaningful value for $DISPLAY
    Start any X application, say xterm.

    xterm

    The xterm window should open successfully.
    ----------------------------------------------------------------------------
    But it just did not work. I opened the Putty console, i check my DISPLAY variable, it was not set, then i set it explicitily, but when i try to run X application, i get the message that protocol is not mentioned. I am totally confused

  11. #10
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Sorry. I've never seen a "protocol is not mentioned" message when attempting to run an X app, so I don't have a clue. Must be something to do with Slackware. What you're doing looks correct, and works like a charm for me when accessing RHEL4, RHEL5, and Fedora 10-15. I just checked a RHEL4 and a RHEL5 session in which I've run X apps, and both have "DISPLAY=localhost:10.0". I didn't have to set the DISPLAY variable, it happened automagically.

    Good luck. I think you may need a X-on-Slackware expert.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •