Find the answer to your Linux question:
Results 1 to 4 of 4
Hey, I've been running slackware 13.37 32-bit for a while dual-booting windows 7, but I quickly realised I want to create my own linux and start working around from there. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2012
    Posts
    7

    LFS on a Slackware system


    Hey,

    I've been running slackware 13.37 32-bit for a while dual-booting windows 7, but I quickly realised I want to create my own linux and start working around from there.
    I'm following the LFS (Linux from scratch) guide which is great, but slackware/linux itself is causing me some trouble. It would be great if somebody could help me out here.

    1. Lilo: I was disconnecting/reconnecting some external HDs and maybe an internal one as well (note that linux and slackware are on the same hd). When I tried to login through lilo it couldn't find linux. So I went into gparted and found that the partition path was changed from sdb1 to sdc1. So when I logged in through "Linux root=/dev/sdc1" it came up with various errors that internal parts are supposed to be in sdb1 (obviously due to the global renaming of sdb1 to sdc1)

    Meanwhile windows didn't have this problem. So how can I prevent this from happening again? Or alternatively how can I rename the path?

    2. While installing/upgrading packages for LFS and to compile a kernel (GCC in particular) I do sometimes do a mistake and I'm not sure where what went or how to fix it.

    Is there a way to backup the whole system (like a timemachine) so I don't have to worry too much about it for now?

    3. (not so important) every time I open a file a temporary file of the same name with a "~" is created that seems to stay on the system forever, even for a simple text file. Is there a way to auto-clean it?

    Any help is much appreciated!

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,500
    1. I don't know for sure that lilo can handle them but uuids for your drives are better than device names. As you have found out, device names can change but uuids do not. To identify a devices uuid run
    Code:
    blkid /dev/sda1
    which may need root. It will return something like
    Code:
    /dev/sda1: UUID="80baa4fd-08d2-4036-b86e-b3b3e5597d05" TYPE="ext4"
    to use this in your fstab, you replace the device with uuid=###UUID###, for example from my server
    Code:
    UUID=80baa4fd-08d2-4036-b86e-b3b3e5597d05 /               ext4    relatime,errors=remount-ro 0       1
    [edit]Just found this which is reasonably recent.[/edit]

    2. It's manual but clonezilla may do what you want.

    3. Yes. Have a look at the find command.
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  3. #3
    Just Joined!
    Join Date
    Jan 2012
    Posts
    7
    To the point exactly. Thank you very much!

  4. #4
    Just Joined!
    Join Date
    Jul 2012
    Location
    USA
    Posts
    8
    hi, I just wanted to comment on your post, that I have been trying that, and that book has not even worked for me. So what I have been trying is to statically link all the programs to chroot into the new environment and build the rest from there. I kept running into the error of shared libraries when trying to chroot after building the base system. I thought I would share that with you as a thought.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •