Find the answer to your Linux question:
Results 1 to 2 of 2
Hey guys, i am in dire need of some advice. I have been working on installing Slackware to use on my MacBook Pro (late 2011 version). I am not putting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2012
    Posts
    1

    Unhappy Slackware install problem


    Hey guys, i am in dire need of some advice. I have been working on installing Slackware to use on my MacBook Pro (late 2011 version). I am not putting it on my internal hard drive, but rather am booting it from an external hard drive. I have the partitions and everything setup for the drive and am able to boot into setup and format the partitions. When i go to select the source from the install CD (burnt downloaded iso) , no cd drive is found. I have tried every solution i have found. The cd is either under a different name or no existent in the directories because i have tried to mount every possibility. The odd thing is the cd is recognized on an older Macbook and i can install it through an older mac, but when i plug it into my mac and boot it from rEFIt, i receive a No Operating System error. It seems i have two problems. I can't find the cd drive when trying to setup from my Mac. And when i set it up from another device, the operating system isn't found. Again i am attempting to setup and run Slackware all from an external hard drive. Any advice on either problems is welcome! I have done a lot of research and am not just asking out of the dark. I haven't found anyone able to help yet. i just would like to get it to work haha.

  2. #2
    Just Joined!
    Join Date
    Jun 2012
    Posts
    9
    hello there! i don't own a mac and don't know if it matters. i can describe what i did on my netbook that hasn't an optical drive. i went to a mirror and downloaded the file .../slackware-13.37/usb-and-pxe-installers/usbboot.img.
    than i made a bootable usbstick with it using unebootin (it exists for win and linux. there must be something for mac to do it). after that i booted it and made a network full installation. when setup allowed me i created a syslinux bootstick and i didn't install lilo at the end of the process.
    so i have a machine that boots its windows partition unless i plug the usb stick from wich i can boot linux. now i realize your setting is different. you can do a network installation on your external drive with all the bootloader, but i think i understood reading about the topic that you can still have a boot failure from the internal drive if the externel one is unplugged.
    a way to prevent this and still install lilo on the external drive is by deactivatig the internal one from bios or fisically remove it before the installation process.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •