Find the answer to your Linux question:
Results 1 to 3 of 3
I am trying to install Slackware from a USB. (something I have never done) I am following this guide [ Install Slackware Using A USB Flash Drive - SlackWiki Everything ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Drunk_Mexican's Avatar
    Join Date
    May 2008
    Location
    San Antonio, TX
    Posts
    53

    Slackware install from USB issue


    I am trying to install Slackware from a USB. (something I have never done)

    I am following this guide [Install Slackware Using A USB Flash Drive - SlackWiki

    Everything went fine until the end of the tutorial where the installer asks for a source.

    fdisk -l reveals the usb is recognized as /dev/sdb1p1

    However that did not work.

    I ran cfdisk /dev/sdb and it showed a partition table with sdb1 as a bootable partition with a label of [SlackDVD].

    /dev/sdb1 as a source parition is greeted with a prompt that says it needs to know the full path of the directories containing installation files.

    How do I get the full path? I don't know what to do here I am stuck.

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    3,970
    Have you tried /dev/sdb instead of /dev/sdb1. I ran into this issue with Puppy Linux once.
    By the way. I don't run Slackware.

    Also. Maybe using UUID maybe may be the way to go also.

    Code:
    # blkid
    /dev/hda1: UUID="EC74EAD474EAA096" TYPE="ntfs" 
    /dev/hda3: UUID="aac76329-7a74-45c5-b9eb-f6e675a1f939" TYPE="swap" 
    /dev/hda4: LABEL="/" UUID="856fa346-17f4-43ad-90f9-0277bb8cdde5" TYPE="ext4" 
    /dev/hda5: LABEL="/home" UUID="3620a6b2-99ec-4cc9-8fed-b36a662d79e7" TYPE="ext3" 
    /dev/hda6: LABEL="/" UUID="33d2cb14-08cc-4db8-80c6-771828e68200" TYPE="ext3" 
    /dev/hda7: UUID="f32a719a-19dd-432f-8178-9e3486ffbe13" TYPE="ext3" 
    /dev/hda8: LABEL="/data1" UUID="E9A8-C3E1" TYPE="vfat"
    Good luck with it.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined! Drunk_Mexican's Avatar
    Join Date
    May 2008
    Location
    San Antonio, TX
    Posts
    53
    Well I finally got some free time and I figured it out.

    To recap: Follow this tutorial. Install Slackware Using A USB Flash Drive - SlackWiki
    Follow it exactly. (I am not kidding). I used a Slack 13.37 DVD iso. The full enchilada but before you head out look in it to find where the program directory tree is. Mine was in /slackware.

    Before I ran setup I did fdisk -l and found what my usb was called. In this case it was /dev/sdb1.

    Make a directory and mount the usb. <mkdir bozo> then <mount -t auto /dev/sdb1 /bozo>
    Then <cd /bozo> and enter <ls> You should see the /slackware tree there with all the progam goodies.

    When it got to Source Media Selection I went for option 6: 'Install From a Pre Mounted Directory'

    I should have been using that, not option 2.

    When the promt comes up to eneter the path for me it was /bozo/slackware and the install went fine.


    I now have Slackware

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •