Find the answer to your Linux question:
Results 1 to 6 of 6
hi, everybody! i have been trying to install perl on slackware v10. after doing the following: root@zipslack:~# gzip -d perl-5.8.1.tar.gz [ENTER] root@zipslack:~# cp -i perl-5.8.1.tar /usr/src [ENTER] root@zipslack:~# cd /usr/src ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    6

    error installing perl - c compiler not working


    hi, everybody!

    i have been trying to install perl on slackware v10.

    after doing the following:

    root@zipslack:~# gzip -d perl-5.8.1.tar.gz [ENTER]

    root@zipslack:~# cp -i perl-5.8.1.tar /usr/src [ENTER]

    root@zipslack:~# cd /usr/src [ENTER]

    root@zipslack:/usr/src# tar xvf perl-5.8.1.tar [ENTER]

    root@zipslack:/usr/src# cd perl-5.8.1 [ENTER]

    root@zipslack:/usr/src/perl-5.8.1# rm -f config.sh Policy.sh [ENTER]

    root@zipslack:/usr/src/perl-5.8.1# sh Configure [ENTER]

    ... I get the following error:

    "... the C compiler 'cc' doesn't seem to be working. You need to find a working C compiler."

    i already checked my installation of gcc. looks fine after i ran "gcc -v".

    i can install using an slackware package but i want to install/compile from a compressed archive. :)

    thanks in advance!

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Find the path to gcc, usually /usr/bin/gcc. Do this with 'which gcc'. Then set the variable to the path to gcc, like this 'CC=path'. Then try again.

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    6

    dependency problems

    hi, valan. thanks for the suggestion. tried it but no luck.

    anyway, i suspected that the problem is with dependencies. to remedy this, i re-installed make. in addition, i installed binutils and kernel-headers. the source did compile thereafter.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    Did you install the full Glibc package or just the so-libs. You'll need the full version. It's in the slackware/l dir on your installation CD/dir
    I\'m so tired .....
    #200472

  6. #5
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Install the gcc package from the cd.

  7. #6
    Just Joined!
    Join Date
    Dec 2004
    Posts
    6

    ok now

    it is ok now. perl is installed.

    glibc files (i.e., glibc, glib and glib2) are installed. i got them from the slackware website and installed them on the zipslack installation, which i transferred from a windows partition to its own (linux) partition.

    gcc is installed the same way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •