Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, I`m kinda new to Slackware, and I`m having trouble when opening firefox. When I run it from the "run" window it opens and then crashes after 10 seconds, this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2011
    Posts
    8

    Problem with firefox


    Hello, I`m kinda new to Slackware, and I`m having trouble when opening firefox. When I run it from the "run" window it opens and then crashes after 10 seconds, this is probably the firefox I got with slackpg. However, when I run it from the terminal, it works perfectly, and this leads me to believe that I have two versions of firefox installed, but I can`t figure out anything beyond that. I`m a real newbie that read all the documentation I could, but still can`t figure out what`s going wrong.

    Any tips?

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    see if your theory about multiple version of firefox is correct first. in a terminal window try:

    Code:
    which firefox
    
    whereis firefox
    once you know full paths, you can do this to get version info:

    Code:
    firefox -version

  3. #3
    Just Joined!
    Join Date
    Oct 2011
    Posts
    8
    Code:
    which firefox
    /usr/bin/firefox
    Code:
     whereis firefox
    firefox: /usr/bin/firefox /usr/X11R6/bin/firefox /usr/bin/X11/firefox /usr/X11/bin/firefox
    Code:
     bash-4.1$ firefox -version
    Mozilla Firefox 14.0.1
    what do I do now? I mean, I`d like to run the version I downloaded from their official website, but it can`t figure out how, since if I try to run it from the "run" window it opens the one I got from slackpkg.

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    which is the one you downloaded from their website, do you know? i'm not familiar with SLackware, but maybe if you make up whatever /usr/bin/firefox is and replace it with a symlink pointing to the one you want, that would work.

    but your "firefox -version" command makes me think you've got the right one in /usr/bin/firefox already. maybe try backing up the other ones temporarily (provided they are not symlinks pointing to /usr/bin/firefox). e.g.:

    Code:
    mv /usr/bin/X11/firefox /usr/bin/X11/firefox.bak

  5. #5
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    If you happen to have FF14 from a slackpkg update && slackpkg upgrade-all for a system update, then you have the version from the official repos. The DL from the Mozilla site isn't needed, and might cause some issues with run-time plug-ins.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  6. #6
    Just Joined!
    Join Date
    Oct 2011
    Posts
    8
    It seems that I have only one version from slackpkg. However, the problem persists: if I run it through the terminal, it works perfectly, but if I run it from the "run command" window, it crashes after 10 seconds approximately. In addition, when I re-open them, each one tries to restore a different session (group of tabs), that`s why I thought it wasn`t the same instalation. Funny...

    Any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •