Find the answer to your Linux question:
Results 1 to 2 of 2
I just installed Slackware 10.0 and am having a little trouble with my mouse. Where can i modify the settings for it? Running KDE and tried the control center but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    1

    trouble with my mouse.


    I just installed Slackware 10.0 and am having a little trouble with my mouse.
    Where can i modify the settings for it? Running KDE and tried the control center but it doesnt seem to load. Using an old serial mouse with pci motherboard. pIII550

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    For a serial mouse, make sure the mouse device is pointing to the correct actual device. If your mouse is plugged in to the "com 1" port, that's equivalent to /dev/ttyS0. Note that that is a CAPITAL S followed by a zero. "com 2" would be /dev/ttyS1, etc. Check like this:
    Code:
    $  ls  -l  /dev/mouse
    lrwxrwxrwx    1 root     root           10 Aug 20 21:57 /dev/mouse -> /dev/ttyS0
    $
    If it says '/dev/mouse -> /dev/psaux', that means the /dev/mouse device is pointing to the ps/2 port. Change it like this:
    Code:
    $  ln  -s  /dev/ttyS0  /dev/mouse
    I'm not sure, but you may need to be root or superuser to do this and you may need to delete the incorrect /dev/mouse before making a new one.

    That next thing is to make sure your /etc/X11/xorg.conf file is correct. About half-way into the file, you should see something like this:
    Code:
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "Microsoft"
    	Option	    "Device" "/dev/ttyS0"
    EndSection
    If you edit the file in X windows, you will need to log out of X and log back in (not reboot like the other windows...). Note that in all cases, if your mouse is "com2" instead of "com 1", make sure you refer to "ttyS1" instead of "ttyS0". If you need more information, you might try reading the manual page for XF86Config (or is it xorg.conf for newer versions?):
    Code:
    $  man  XF86Config
    /IMHO
    //got nothin'
    ///this use to look better

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •