Find the answer to your Linux question:
Results 1 to 2 of 2
I am unable to get sound working in Slackware 14 on my Lenovo W530. The audio device is: Code: 00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jul 2007
    Posts
    111

    Lenovo W530 sound in Slackware 14


    I am unable to get sound working in Slackware 14 on my Lenovo W530.

    The audio device is:

    Code:
    00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
            Subsystem: Lenovo Device 21f6
            Kernel driver in use: snd_hda_intel
    cat /proc/asound/card*/codec* |grep codec gives me:

    Code:
    Codec: Realtek ALC269VC
    I have tried to create a file in /etc/modprobe.d/snd-hda-intel.conf with the content:

    Code:
    options snd-hda-intel model=auto
    I have the kernel modules loaded:

    Code:
    lsmod |grep snd
    snd_seq_dummy           1455  0 
    snd_seq_oss            29048  0 
    snd_seq_midi_event      5620  1 snd_seq_oss
    snd_seq                51265  5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
    snd_seq_device          5228  3 snd_seq,snd_seq_oss,snd_seq_dummy
    snd_pcm_oss            39183  0 
    snd_mixer_oss          15404  1 snd_pcm_oss
    snd_hda_codec_realtek   195474  1 
    snd_hda_intel          23267  0 
    snd_hda_codec          81925  2 snd_hda_intel,snd_hda_codec_realtek
    snd_hwdep               6324  1 snd_hda_codec
    snd_pcm                72864  3 snd_hda_codec,snd_hda_intel,snd_pcm_oss
    snd_page_alloc          7081  2 snd_pcm,snd_hda_intel
    snd_timer              18798  2 snd_pcm,snd_seq
    snd                    57796  12 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_realtek,thinkpad_acpi,snd_mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_seq_oss
    soundcore               5474  1 snd
    In conclusion I have the kernel modules loaded, and it should work, however I have no sound. I get errors from audio players such as (from Audacious): "ALSA error: No suitable mixer element found.".

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,158
    It is probably just that your alsa mixer settings are not correct. You probably need to enable your alsa mixer PCM sound device (hardware). Run the alsamixer command line application and turn up the volume for the PCM device.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •