Find the answer to your Linux question:
Results 1 to 1 of 1
Hi all! Im running -current and I ran into a strange problem; my touchpad doesn't work anymore, I can move the pointer around, also tapping works but when I right-click ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2013
    Posts
    1

    Touchpad: right-click and scrolling don't work


    Hi all!

    Im running -current and I ran into a strange problem;
    my touchpad doesn't work anymore, I can move the pointer around, also tapping works but when I right-click or left-click, they both operate as a single left click, I cannot scroll up or down either.

    I have xf86-input-evdev, xf86-input-synaptics installed, kept to their default configs, I've installed xf86-input-mouse too but I still have this problem.

    If I'm not wrong; this problem surfaced as I was trying to switch to -current and multilib from 13.37

    Troubleshooting:

    -Booting with a liveCD shows that the touchpad works fine, so the hardware is okay.

    -Rsync slackware64-current and rufollow upgrade instructions to replace all the files before switching to multilib again. Everything works perfectly except for the touchpad

    Thank you in advance!

    Edit:
    Okay found a work-around;
    I shamelessly stole a working synaptics config from a ubuntu Live CD and copied it to /etc/X11/xorg.conf.d/
    Everything works now!
    Last edited by Spiritual_fraud; 03-24-2013 at 12:40 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •