Find the answer to your Linux question:
Results 1 to 2 of 2
Trying to get any modern laptop (with Optimus) to work in Slackware appears to be a nightmare, even if it is a Thinkpad. I cannot get X to work at ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jul 2007
    Posts
    111

    W530 and black/blank screen in X


    Trying to get any modern laptop (with Optimus) to work in Slackware appears to be a nightmare, even if it is a Thinkpad.

    I cannot get X to work at all in Slackware 14.0 on a Lenovo W530.

    The machine has an nVidia Quadro K1000M and the integrated Intel "Ivy Bridge Graphics Controller (rev 09)".

    The BIOS is pretty good. I can select between ONLY using integrated graphics (Intel), ONLY using discrete graphics (nVidia) or using Optimus which combines the two.

    However, regardless of what I choose in the BIOS, I cannot get X to show anything. It either fails to even start, or it shows a blank or black screen -- depending on settings I may be able to kill the server using ctrl+alt+backspace.

    I have tried the 3.2.29 default kernel.
    I have tried a custom compiled 3.7.2 kernel and a custom compiled 3.9.5 kernel.

    I have tried the NVIDIA-Linux-x86_64-310.44.run driver package as well as the latest NVIDIA-Linux-x86_64-319.23.run driver package. It compiles and installs with no issues.

    Using 3.2.29:

    I can boot into init 3 without using nomodeset, and it automatically switches to a higher resolution. Regardless of BIOS settings and regardless of what driver I use in xorg.conf, it will either fail to start with no screens found, or start, showing a blank screen.

    I have tried the driver "nvidia", "intel" and "vesa". I specify the BusID after running X -configure to get it to list out everything.

    Using 3.9.5:

    I CANNOT boot into init 3 wihtout using nomodeset. The display turns blank when KMS is initialized (I believe). If I use nomodeset I experience the same problems as before when attempting to start X.

    From dmesg I can see:

    Code:
    [drm:drm_pci_agp_init] *ERROR* Cannot initialize the agpgart module.
    DRM: Fill_in_dev failed.
    This happens repeatedly when i rmmod i915 and modprobe i915.

    I have updated to the latest BIOS for the W530 (version 2.53).

    The error from xorg is "(EE) No devices detected".

    Does anyone have any idea how to make this work, is it even possible?
    Last edited by corge; 06-13-2013 at 02:14 PM.

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,492
    Maybe Bumblebee is all you need?
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •