Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 25 of 25
# This loads the GLX module Load "glx" # libglx.a Load "dri" # libdri.a these are direct out of the XF86config-4 file which is linked to xorg.conf i have Xorg ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Enthusiast carlosponti's Avatar
    Join Date
    Dec 2004
    Location
    Oklahoma
    Posts
    560

    # This loads the GLX module
    Load "glx" # libglx.a
    Load "dri" # libdri.a

    these are direct out of the XF86config-4 file which is linked to xorg.conf

    i have Xorg btw for all of you running xorg you have to run the fglrxconfig and let it copy to the default file of XF86config-4 then link it , after backing up your xorg.conf file of course, to xorg.conf. if it gives you an error of cant find device you have to cat /proc/pci and get the bus id of your particular video card. On mine there were two one for video 1 and video 2 and for some reason it was selecting video 2 output and i had to select video 1 output.
    Blog
    Registered Linux user 396557

  2. #22
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    Did you check the logfile ? It is /var/log/Xorg.0.log ? Are there any (EE) lines ? If so please post them here .
    I\'m so tired .....
    #200472

  3. #23
    Linux Enthusiast carlosponti's Avatar
    Join Date
    Dec 2004
    Location
    Oklahoma
    Posts
    560
    this is something i noticed
    (II) fglrx(0): UMM area: 0xb0954000 (size=0x076ac000)
    (II) fglrx(0): driver needs XFree86 version: 4.3.x
    (WW) fglrx(0): could not detect XFree86 version (query_status=-3)
    (II) Loading extension ATIFGLRXDRI
    (II) fglrx(0): doing DRIScreenInit

    this is the error listed.
    (EE) fglrx(0): DRIScreenInit failed!
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *
    Blog
    Registered Linux user 396557

  4. $spacer_open
    $spacer_close
  5. #24
    Just Joined!
    Join Date
    Jan 2005
    Posts
    1
    Hi carlosponti. I was just wondering if you've managed to fix this issue. I am having the exact same problem with my Radeon 9200 PCI. DRI does not start properly and thus I can't play ut2004. Did you manage to get it working?

  6. #25
    Linux Enthusiast carlosponti's Avatar
    Join Date
    Dec 2004
    Location
    Oklahoma
    Posts
    560
    nope and i got a new motherboard and CPU and I am starting over. i am trying to get moved from 6.7 to 6.8, on xwindows, and ran into issues with not knowing what packages i need installed before i can do that. i think glib is one package and i have been told that xorg may only have that one requirement but i havent tried updating it yet either. after i get to 6.8 xorg i plan on trying to load the 6.8 ATI drivers.
    Blog
    Registered Linux user 396557

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •