Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I have just started using Slackware after using Redhat Linux 8 up to Fedora Core 3. Is there some vim configuration file that I can copy from my old ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Location
    Malta
    Posts
    41

    vim configuration


    Hi,

    I have just started using Slackware after using Redhat Linux 8 up to Fedora Core 3. Is there some vim configuration file that I can copy from my old FC3 installation to the Slackware installation since I am having trouble using vim on Slackware (e.g. my backspace and delete buttons do not delete anything when I am using vim in INSERT mode).

    Thanks for your help
    is-serp

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    That setting would be (IIRC):

    Code:
    set nocompatible
    You can put that in your ~/.vimrc or your /etc/vim/vimrc (global settings). Those are the files that you want to copy over to preserve any other settings from your previous install(s).
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    May 2004
    Location
    Malta
    Posts
    41
    Thanks for your help. The
    Code:
    set nocompatible
    option helped with the delete button but after a brief seach on google I found that to fix the problem with the backspace key in insert mode another option
    Code:
    set bs=2
    needs to be set.

    Regards
    is-serp

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2004
    Location
    Vienna, Austria
    Posts
    10

    vim configuration

    Hi!

    Are you sure that you are using vim?

    I'm asking cause per default vi is a symbolic link to elvis!

    so try out

    ls -l /usr/bin/vi

    if vi points to elvis, then rm vi and set a symbolic link to vim

    then edit your ~/.vimrc and add following lines

    "activating backspace
    set backspace=2

    ""and additionally here are some suggestions

    "set tabstop=4
    " syntax on
    " map <Esc><Esc> :w <CR>
    " set tabstop=4
    "set autoindent
    " set hlsearch

    well, and thre are many more of course ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •