Find the answer to your Linux question:
Results 1 to 6 of 6
Hello everyone, I have a Slackware 14.0 32-bit and I have a TIM internet key Alice ONDA MT503HS I work very well in graphics mode using KDE and kppp. Now ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011
    Posts
    10

    internet key in Slackware started in text mode (non-graphic)


    Hello everyone,
    I have a Slackware 14.0 32-bit and I have a TIM internet key Alice ONDA MT503HS I work very well in graphics mode using KDE and kppp.
    Now I want to use this key in Slackware started in text mode (not KDE).
    What should I install to run the key, what program to use ?

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    You need a terminal-based program that interfaces with pppd, it sounds like. Try WvDial, for starters.

  3. #3
    Just Joined!
    Join Date
    Dec 2011
    Posts
    10
    Yes, I have already tried with wvdial, but it seems not work on Slackware 14. What should I do and know how to give commands in AT using ppp.
    For example using kppp in the configuration:
    Modem = /dev/ttyUSB0
    Baud = 460800
    Init1 = ATZ
    Init2 = AT+CGDCONT=1,"IP","ibox.tim.it"
    Phone = *99#
    Username = 'tim'
    Password = 'tim'
    I have to find a way to bring Init1 and Init2 in a startup script for ppp. But I do not know how to do

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by giorgik View Post
    Yes, I have already tried with wvdial, but it seems not work on Slackware 14. What should I do and know how to give commands in AT using ppp.
    Take a look at this tutorial. It explains various methods for setting up pppd, including wvdial configuration.

  5. #5
    Just Joined!
    Join Date
    Dec 2011
    Posts
    10
    the file /etc/wvdial:
    Code:
    [Dialer Defaults]
    Modem = /dev/ttyUSB0
    Baud = 460800
    Init1 = ATZ
    Init2 = AT+CGDCONT=1,"IP","ibox.tim.it"
    Stupid Mode = 1
    Dial Command = ATDT
    ISDN = 0
    Modem Type = Analog Modem
    Carrier Check = no
    Phone = *99#
    Ask Password = off
    the file /etc/resolv.conf
    Code:
    search .
    nameserver 10.206.56.132	#kppp temp entry
    nameserver 10.207.43.46	#kppp temp entry
    if I:
    Code:
        bash-4.2# wvdial
        --> WvDial: Internet dialer version 1.61
        --> Initializing modem.
        --> Sending: ATZ
        OK
        --> Sending: AT+CGDCONT=1,"IP","ibox.tim.it"
        AT+CGDCONT=1,"IP","ibox.tim.it"
        OK
        --> Modem initialized.
        --> Sending: ATDT*99#
        --> Waiting for carrier.
        ATDT*99#
        CONNECT
        --> Carrier detected.  Starting PPP immediately.
        --> Starting pppd at Fri Nov  8 18:23:49 2013
        --> Pid of pppd: 8444
        --> Using interface ppp0
        --> pppd: `8 6
        --> pppd: `8 6
        --> pppd: `8 6
        --> pppd: `8 6
        --> pppd: `8 6
        --> pppd: `8 6
        --> local  IP address 2.194.47.239
        --> pppd: `8 6
        --> remote IP address 10.64.64.64
        --> pppd: `8 6
        --> primary   DNS address 10.206.56.132
        --> pppd: `8 6
        --> secondary DNS address 10.207.43.46
        --> pppd: `8 6
    If I:
    Code:
    ping -c3 google
    What's wrong ?

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    do you have a default route set?

    Code:
    route -n
    i don't use dial-up, so not sure what it would be or how you'd get it. but your packets need to know where to route though to get out (find DNS, etc.).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •