Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, Running Slackware 14.1 with XFCE 4.1 and Shotwell and Transmission are not looking great. If you look at the attached screenshots there they appear black with white text and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2011
    Posts
    42

    Shotwell and Transmission don't look right on XFCE


    Hi,

    Running Slackware 14.1 with XFCE 4.1 and Shotwell and Transmission are not looking great.

    If you look at the attached screenshots there they appear black with white text and the menu items closely spaced.

    Am I missing a package to get these looking right or are they not designed to work with XFCE?
    Attached Images Attached Images

  2. #2
    Just Joined!
    Join Date
    Dec 2013
    Posts
    9
    Looks more like a theme problem. I assume you built from slackbuilds?

    shotwell is definitely a gtk+3.0 app these days, so you will probably need to install some themes and manually configure the theme you want to use by default or install something to allow switching (no idea here as I mostly avoid gtk+3.0/gnome 3.x stuff like the plague).

    transmission-gtk is also a gtk+3.0 application, but there is an alternative qt4 front end by default, try running transmission-qt

    Xfce4 is still built on gtk+2.0 which is why your Xfce4 theme doesn't take effect for those applications.

  3. #3
    Just Joined!
    Join Date
    Oct 2011
    Posts
    42
    Quote Originally Posted by flunwyc View Post
    Looks more like a theme problem. I assume you built from slackbuilds?

    shotwell is definitely a gtk+3.0 app these days, so you will probably need to install some themes and manually configure the theme you want to use by default or install something to allow switching (no idea here as I mostly avoid gtk+3.0/gnome 3.x stuff like the plague).

    transmission-gtk is also a gtk+3.0 application, but there is an alternative qt4 front end by default, try running transmission-qt

    Xfce4 is still built on gtk+2.0 which is why your Xfce4 theme doesn't take effect for those applications.
    Thank you.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •