Find the answer to your Linux question:
Results 1 to 5 of 5

Thread: 14.2 Beta

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Location
    Ware Shoals, SC
    Posts
    17

    Wink 14.2 Beta


    I downloaded and burned the new Slackware 14.2 Beta last weekend. It's been a trial getting it going, but I've get WiFi, during an X session. I did not follow the instructions when installing AMD latest drivers, however, so X is now a blank screen. Does anyone know the best way to back out the corrupted AMD drivers and reinstall the VESA drivers? This would of course be temporary, until I can figure out the AMD drivers. I'm not afraid of the command line, I'm just not very fast with it. Lol

  2. #2
    Just Joined!
    Join Date
    Oct 2005
    Location
    Ware Shoals, SC
    Posts
    17
    I reinstalled the whole thing to get x working again. I still can't get the AMD installer to generate a module package for the Video. So I guess I'm using mesa drivers for now. I did find the install logs, if anyone wants to see. I couldn't figure anything out by looking at them.

    Check if system has the tools required for Packages Generation.
    AMD kernel module generator version 2.1
    doing Makefile based build for kernel 2.6.x and higher
    rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
    make -C /lib/modules/4.4.0/build SUBDIRS=/home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x modules
    make[1]: Entering directory '/usr/src/linux-4.4'
    CC [M] /home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
    /home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'firegl_major_proc_read':
    /home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:634:9: error: void value not ignored as it ought to be
    len = seq_printf(m, "%d\n", major);
    ^
    /home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_fpu_save_init':
    /home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:6458:49: error: 'XSTATE_FP' undeclared (first use in this function)
    if (!(fpu->state.xsave.header.xfeatures & XSTATE_FP))
    ^
    /home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:6458:49: note: each undeclared identifier is reported only once for each function it appears in
    /home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
    /home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:6448:12: warning: 'KCL_fpu_save_init' defined but not used [-Wunused-function]
    static int KCL_fpu_save_init(struct task_struct *tsk)
    ^
    scripts/Makefile.build:258: recipe for target '/home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o' failed
    make[2]: *** [/home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
    Makefile:1384: recipe for target '_module_/home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x' failed
    make[1]: *** [_module_/home/eyeinidas/Downloads/fglrx-15.302/fglrx-install.tExKmh/common/lib/modules/fglrx/build_mod/2.6.x] Error 2
    make[1]: Leaving directory '/usr/src/linux-4.4'
    Makefile:88: recipe for target 'kmod_build' failed
    make: *** [kmod_build] Error 2
    build failed with return value 2
    ERROR: I didn't make module
    [Error] Generate Package - error generating package : Slackware/Slackware

  3. #3

    kernel version too high for amd drivers

    greetings,

    slackware-current comes with linux kernel 4.4.

    the current AMD drivers only compile with kernels up to 3.19. new support is proposed for the newer kernels in a later AMD release.

    you'll see other posts from opensuse and gentoo users with similar issues.

    most of the mainstream linux distros run with much older kernels and thus aren't affected. i see a lot of older packages on non-slackware stuff.

    slackware tends to be the latest and greatest at the time of release. that sometimes means the other third party vendors are behind.

    i think nvidia got the leap ahead with support for the newer kernels. they also only provide a closed binary driver.

  4. $spacer_open
    $spacer_close
  5. #4
    Slckware 14.2 Beta ships with the Linux 4.4 LTS kernel, many new packages were added, the AMDGPU X.Org driver is now present, GCC 5.3 is now the default compiler, eudev has replaced udev, and there are many other changes. Slackware continues to ignore systemd.

  6. #5
    Just Joined!
    Join Date
    Oct 2005
    Location
    Ware Shoals, SC
    Posts
    17
    -->
    I appreciate the help. I'm going for the 14.2 RC1 this weekend. I'll also check with AMD to see if they have anything new. If not, I'll just use the video the way it is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •