Find the answer to your Linux question:
Results 1 to 8 of 8
I have installed Slackware 10 on my Laptop. I was able to get the 1280x800 screen working. When I add the line: Load "dri" The laptop locks up when I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6

    Slackware 10 Video Works. But Load "dri" freezes


    I have installed Slackware 10 on my Laptop. I was able to get the 1280x800 screen working. When I add the line: Load "dri" The laptop locks up when I start X and has to be turned off, ctrl-alt-del does not work, nor ctrl-alt-f2 nor ctrl-alt-backspace.

    I have installed Slackware 10 off the CD. Then Xorg version 6.8.1 and Slackware 10.1. None will work when DRI is enabled. If I comment out the Load "dri" line X works fine, but then I get direct renderng disable, of course.

    I have SuSE successfully installed and running on the same laptop and direct rendering works fine.

    I even copied the SuSE XF86Config file to my xorg.conf. I know the shame, but desperte times call for desperate measures. And it did not work.

    I have search the Internet and have not been able to find much about getting dri to work when the video is already working. It seems that it is all or none. None has lots of solutions, but partial working does not.

    The only thing I have been able to figure out is that the Slackware drivers are newer than the SuSE drivers. I looked around the sub-directories, but could not find anything that leads me to what is actually wrong.

    Here is the file listings (Slackware 1st and SuSE 2nd):
    32318 2004-10-18 15:46 /usr/X11R6/lib/modules/extensions/libdri.a
    30314 2004-10-04 10:55 /mnt/suse/usr/X11R6/lib/modules/extensions/libdri.a

    and

    38478 2004-10-18 15:46 /usr/X11R6/lib/modules/linux/libdrm.a
    38010 2004-10-04 10:55 /mnt/suse/usr/X11R6/lib/modules/linux/libdrm.a

    I am not sure which way to proceed. I don't want to start copying old files over newer files. And more imporatantly I don't want to chase down something that is not going to fix my problem

    Any suggestions on how to proceed?

    TIA

    -JJ

  2. #2
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    Did you install all of Slackware-current or just a selection of packages ? Slackware 10.0 is the latest stable version and Slackware-current packages installed on a 10.0 system could work or could not work. The more the current version moves toward release the less the chance will be that packages will work on different Slackware versions.

    I copied my original XF86Config to xorg.conf and that worked fine, so that could work. But if you are using X.org > 6.7.0 the keyboard driver has to be changed to kbd .

    What I like to know is following:
    - How did you install Slackware-current ? (I refuse to use 10.1 because that has not been released yet)
    - Did you did a complete re´nstall or copied just a few packages ?
    - What is the exact error message ? (/var/log/Xorg.0.log )
    - Your X.org config file .

    I have X.Org 6.8.1 running on a 10.0 system with DRI enabled.
    I\'m so tired .....
    #200472

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    I have 3 slackware installations:
    slackware - virgin: install from the CD, no updates.
    slackware - test: installed from the CD; updated X.org 6.8.1 and KDE 3.3.2
    slackware - prod: installed from 10.1 files downloaded.

    All were install everything except the foreign languages.

    I caught the driver to kyb change. It is configured correctly in 10.1.

    None work with 'Load "dri"'

    When X crashes, it does not write a Xorg.0.file. I think it is crashing before it get a chance to write anything.

    Here is my xorg.conf file. I removed the header comments, if you need me to post the file with those, I can edit or repost.

    Thank you for helping.

    -JJ
    ==============
    Section "Module"
    Load "dbe" # Double buffer extension

    SubSection "extmod"
    Option "omit xfree86-dga" # don't initialise the DGA extension
    EndSubSection

    Load "type1"
    Load "freetype"
    #Load "speedo"
    Load "glx"
    # Load "v4l"
    # Load "dri"
    EndSection

    # Section "DRI"
    # Mode 0666
    # EndSection

    Section "Files"
    RgbPath "/usr/X11R6/lib/X11/rgb"
    FontPath "/usr/X11R6/lib/X11/fonts/local/"
    FontPath "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic/"
    EndSection

    Section "ServerFlags"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    EndSection

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "PS/2"
    Option "Device" "/dev/mouse"
    EndSection

    Section "Monitor"
    Identifier "My Monitor"
    HorizSync 30-82
    VertRefresh 58-75
    EndSection

    Section "Device"
    Identifier "Radeon Card"
    Driver "radeon"
    VendorName "ATI"
    #VideoRam 4096
    EndSection

    Section "Screen"
    Identifier "Screen 1"
    Device "Radeon Card"
    Monitor "My Monitor"

    # DefaultDepth 8
    DefaultDepth 16
    # DefaultDepth 24
    # DefaultDepth 32

    Subsection "Display"
    Depth 8
    Modes "1280x800" "1024x760"
    EndSubsection
    Subsection "Display"
    Depth 16
    Modes "1280x800" "1024x768"
    EndSubsection
    Subsection "Display"
    Depth 24
    Modes "1280x800" "1024x768"
    EndSubsection
    Subsection "Display"
    Depth 32
    Modes "1280x800" "1024x768"
    EndSubsection
    EndSection

    Section "ServerLayout"
    Identifier "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
    EndSection

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    I compiled the ATI drivers into the kernel. It still locks up when I start X.

    I did get sound working in terminal mode, but it does not work in X. But that is a future problem, right not I just want to get rendering working.

    -J

  5. #5
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    First of all ati+linux is still a bad combo

    And from my own experinece kernel radeon drivers + dri + slackware never worked, but with ati.com drivers i got it to work following this guide http://www.linuxforums.org/forum/topic-21368.html

    it worked, almost perfectly, i say almost because after starting x with ati.com driver i could not make a clean shutdown, i hope this new driver, which is builded for Xorg, is going to work.

    did not tested it yet, but u should give it a try

  6. #6
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    Unfortunately it is what I got. Since SuSE runs on my laptop, slackware should run as well, I just need to find the right tweak, driver, etc.

    I downloaded the new ati drivers and will be installing them this morning, I'll report here how it all goes.

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    I got lost in what went where and decided to reinstall my two test slack partitions. I have to put this in the back burner for a couple of days, but will pick it all up over the weekend for sure.

    -J

  8. #8
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    Back at it again. Got the 2.6.10 kernel working still fine tuning it. Have not gotten to loading dri.... yet. Wanted to get everything else working before I tackled that one.

    The /var/log/messages file is getting flooded with /etc/udev/rules.d/udev.rules messages. Is there a way to turn it off? There are no errors, just lots of messages about adding links. I think somewhere I turned on vvvvv debugging.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •