Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Slackware Nvidia GeForce 7025 / nForce 630a problem


    Hi, I'm new to Slackware. Sorry, my Nvidia display card could not be set up like other distributions. How do I do it?

    Code:
    lspci | grep VGA ; lsmod | grep "kms\|drm" ; find /dev -group video ; \ cat /proc/cmdline ; find /etc/modprobe.d/; cat /etc/modprobe.d/*kms* ; \ ls /etc/X11/xorg.conf ; glxinfo | grep -i "vendor\|rendering" ; \ grep LoadModule /var/log/Xorg.0.log
    Top code output

    00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
    drm_kms_helper 118812 1 nouveau
    drm 323478 6 ttm,drm_kms_helper,nouveau
    agpgart 31796 3 drm,ttm,nouveau
    fb_sys_fops 1730 1 drm_kms_helper
    syscopyarea 3458 1 drm_kms_helper
    sysfillrect 3950 1 drm_kms_helper
    sysimgblt 2608 1 drm_kms_helper
    i2c_core 47925 6 drm,i2c_dev,drm_kms_helper,i2c_algo_bit,nouveau,i2 c_nforce2
    /dev/fb0
    /dev/dri/card0
    /dev/dri/renderD128
    /dev/dri/controlD64
    bash: cat: no command
    /etc/modprobe.d/
    /etc/modprobe.d/README
    cat: '/etc/modprobe.d/*kms*': No such file or directory
    bash: ls: no command
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual or fbconfig
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    bash: grep: no command

    LZ7bjJ.png r6BO7B.png

    77E64m.png Pn4lgv.png

    g2zOBL.png
    Reboot
    The desktop does not open. However, deleting the xorg.conf file opens the Desktop. I can not activate the Nvidia settings panel. How do I do this?

  2. #2
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,901
    Disclaimer,I have not tried these instructions.
    Slackware is a do-it-yourself distro. It is meant for those who want complete control of there computers. No native package managers.

    https://docs.slackware.com/howtos:ha...aphics_drivers
    If you want to learn more about linux take a linux journey
    https://linuxjourney.com/
    Use CODE tags when posting output of commands. Thank you.
    https://www.linuxcounter.net/cert/608410.png

  3. #3
    I am doing everything myself by myself. I am interfering with the background staff myself. I do not have a machine graphics card which is a problem (Onboard) so I wanted to own Nvidia 304.132 .. I apologize for the code tags and weak english.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    1,573
    nVidia blob will not load with KMS activated in kernel. And you need a four-line Xorg.conf to load the blob, Xorg will not load it automatically.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •