Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Slackware-current + AMDGPU-Pro drivers = crash X


    I just bought a new rig, and wanted to use the AMD architecture. Hence my build is as following:

    MB - Asus M4A89GTD (with BIOS)
    CPU - AMD Phenom II
    GPU - AMD Radeon RX 550
    (Believe the other parts do not add to the trouble)

    I have had Multilib configured in all my installations

    First I installed Slackware 14.2 (stable) but when testing with some games all graphic processes landed on the CPU resulting me to conclude that Xorg couldn't use the GPU. From this I have figured that I need the AMD drivers to use my GPU.

    But between the testing I have upgraded my system to running Slackware-current (kernel 4.9.45)

    I have ran following script that I found on this forum:

    The modifications I have done to the script is:
    - Changed version number to match the packet I downloaded from in "fwdir.patch" and "kernel-4.10"
    - Removed the first hunk (12 lines) from "kernel-4.4.patch"
    - Removed line 116-118 to "amdgpu-pro.SlackBuild"

    I have tried to install the drivers on both huge.s and generic. I still get the same result. When I run "startx" my screen turns completely black and get no response from neither keyboard nor mouse.

    grep 'EE' /var/log/Xorg.0.log returns:

    [ 1445.907] (EE) Failed to load module "fbdev" (module does not exist, 0)

    [ 1445.917] (EE) open /dev/dri/card0: No such file or directory

    [ 1445.917] (EE) open /dev/dri/card0: No such file or directory

    [ 1445.917] (EE) Screen 0 deleted because of no matching config section.

    [ 1446.764] (EE) AIGLX: reverting to software rendering

    [ 1446.887] (EE) AIGLX error: dlopen of /usr/X11R6/lib64/modules/dri/ failed (/usr/X11R6/lib64/modules/dri/ undefined symbol: is64bitelf)

    [ 1446.888] (EE) GLX: could not load software renderer

    A kind person from reddit told me to check in the folder xorg.conf.d after files named "amd" but I can't find any problems here, but I don't know what to look for.

    Ether way is my whole xorg.conf.d-folder uploaded here in a .Zip

    I have since installed another dist on my machine with AMD-support to be able to use the GPU. But my wishes are to use Slackware 100%
    Attached Files Attached Files

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Contact the Slackware user support forums? They may be able to help.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    [ 1445.917] (EE) open /dev/dri/card0: No such file or directory

    ^^ this means your kernel has no correct driver (module) loaded. Once you get rid of this error we can look further into Xorg configuration. There is also Xorg driver for your graphics that needs to be loaded.

  4. $spacer_open
  5. #4
    Linux Engineer drl's Avatar
    Join Date
    Apr 2006
    Saint Paul, MN, USA / CentOS, Debian, Slackware, {Free, Open, Net}BSD, Solaris

    Also posted at 2017-10-09, 09:12 on

    Good luck ... cheers, drl
    Welcome - get the most out of the forum by reading forum basics and guidelines: click here.
    90% of questions can be answered by using man pages, Quick Search, Advanced Search, Google search, Wikipedia.
    We look forward to helping you with the challenge of the other 10%.
    ( Mn, 2.6.n, AMD-64 3000+, ASUS A8V Deluxe, 1 GB, SATA + IDE, Matrox G400 AGP )

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts