Find the answer to your Linux question:
Results 1 to 8 of 8
i'm running Slack 10 with 2.4.19 kernel and tryed to install nvidia drivers for my GeForce 2, using NVIDIA-Linux-x86-*-pkg1.run , but in the middle of installation it says that it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    22

    Slack 10 + Nvidia


    i'm running Slack 10 with 2.4.19 kernel and tryed to install nvidia drivers for my GeForce 2, using NVIDIA-Linux-x86-*-pkg1.run , but in the middle of installation it says that it couldn't find nvidia.o and suggest to chcec if i have kernel source , it is fact i don't have nvidia.o but i have kernel source of my actual kernel in /usr/src/linux , also tryed the --kernel-source-path with same resuly.

  2. #2
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    I deleted my reply. Slackware 10.0 using 2.4.19 ? Did you compile it yourself and is /usr/src/linux the source for this kernel ? Did you compile the kernel module of NVidia as well ?

    Slackware 10.0 comes default with 2.4.26 IIRC .
    I\'m so tired .....
    #200472

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    22
    damn misstyped i'm using 2.4.29, didn't compile nvidia module in kernel, never had to when i was using debian.

  4. #4
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    Strange, the package should provide the nvidia.o kernel module. Did you disable something/enable something in the kernel config preventing third party kernelmodules from loading ?
    I\'m so tired .....
    #200472

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    22
    no i just compiled kernel like i did everytime in debian and it always was ok , so i can't figure what is wrong.

  6. #6
    Linux User
    Join Date
    Oct 2004
    Location
    Serbia&Montenegro
    Posts
    281
    Try recompiling your kernel and set graphic card as VESA. Then install the driver. It worked for me.

  7. #7
    Just Joined! LinuxBox420's Avatar
    Join Date
    Jan 2005
    Posts
    32
    Did you make any modules when you built your kernel? Look in /lib/modules .The installer can't find a 2.2.29 modules directory if you didn't.

  8. #8
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    Kernel 2.4 is Old. Upgrade to 2.6 already people.
    And there's no nvidia module in the kernel, at least not the one you want.
    Emotions are the key to the soul.
    Registered Linux User #375050

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •