Find the answer to your Linux question:
Results 1 to 6 of 6
Hey there. This is my first time on these forums (and so far they look great), and I came here to get help with something. I already tried the Search ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    5

    Running Slackware on SATA drives


    Hey there. This is my first time on these forums (and so far they look great), and I came here to get help with something. I already tried the Search Function on this forum to try and get my question answered, but with no luck.

    Here is my situation: I have a new box that I put together: the specs don't really matter, except for this:

    I have two 160 gig Seagate SATA drives, running at 7200 RPM.

    Now, I really want to get slackware working on this box. But, when I do cfdisk or fdisk, it can't pick up my drives. Now, I did some research, and found that Slack 10.0 doesn't support SATA. I might also have a problem because of my SATA Controller on my motherboard. The specs on my motherboard for SATA are :
    SATA: 2x Serial ATA with RAID 0/1, 2x Serial ATA by Promise 20378 with RAID 0/1/0+1
    More on that can be found at: http://usa.asus.com/products/mb/sock...d/overview.htm , the site for my motherboard.

    Back to slack. I've found that one of the options would be to manually edit the kernel and get SATA drivers on there, but frankly, I'm really quite a noob with Linux, and that would be quite overwhelming. I've also tried looking for edited versions of Slack that already have the SATA drivers on them, but again, not too much luck. I'm in the middle of downloading a bit torrent name Slackware 10.0 CD1_SATA , but I have no idea what to expect from that.

    Do you guys have any advice for me? Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3

    hmm

    I was able to install slack 10 fine onto my sata hard drive. The one problem that I did have was that it would not install a boot loader into the MBR unless I disconected my ide hard drive.

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    5
    Well, how did you get past the partitioning part? When I do cfdisk, i get something like "Fatal Error, No Drive Exists" , or something

  4. #4
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    When u boot the comp with the CD1 in the drive u should watch closely for lines which contain from /dev/hd* that is the location of your drive.

    make sure u have selected the right kernel, there a couple more options if u press F2 or F3

    after it boots , u can try following command
    Code:
    # dmesg |grep hd
    also u can substitute 'hd' with 'sd'

    afterwords do the following
    Code:
    # cfdisk /dev/hd*
    where * is letter of your drive

    i have installed slack10 on a SATA drive, and mine letter was 'e' and thus i used '/dev/hde'

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3
    Mine was already partitioned because I installed a copy of windows first and used partion magic...
    However max's way should work. it does not place your sata drive in hda and that is the default. My sata is also at /dev/hde/
    The major problem is proably the fact that you are using raid, not that you have sata hard drives.

  6. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    1
    The only way i got my SATA drive working (Seeing as im still a noob to Linux) was to install an old IDE drive, install slack 10 and then install and upgrade to the new kernel 2.6.10.

    The SATA drive was detected as a scsi drive and resides on /dev/sda but i had to enable the option in the kernel though. Think it was under Device Drivers > Scsi Device Support > Scsi Low Level Drivers.

    The SATA drive is mainly in the box for the database i need to run so i would rather use a faster SATA drive than an IDE one. Hope this helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •