Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
My Microsoft USB optical mouse won't work in slack 10.0 can anyone help me or tell me how to configure it to work?? It would be greatly appreciated....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3

    USB optical mouse


    My Microsoft USB optical mouse won't work in slack 10.0 can anyone help me or tell me how to configure it to work?? It would be greatly appreciated.

  2. #2
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    run xorg.conf and then edit /etc/X11/xorg.conf
    make a backup of your original conf file first
    cp xorg.conf xorg.conf.orig

    inside xorg.conf delete the part that looks like this one then add this there and reboot.

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Device" "/dev/mouse"
    Option "Protocol" "PS/2"
    Option "Emulate3Buttons" "off"
    Option "ZaxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "IMPS/2"
    Option "Emulate3Buttons" "off"
    Option "ZAxisMapping" "4 5"
    EndSection

    Let me know if this is not clear
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  3. #3
    Linux User
    Join Date
    Oct 2004
    Location
    Serbia&Montenegro
    Posts
    281
    I don't think that ZaxisMapping works under Slack 10. I've tried several times to fix my wheel but it won't work.

  4. #4
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    Quote Originally Posted by Fallen Angel
    I don't think that ZaxisMapping works under Slack 10. I've tried several times to fix my wheel but it won't work.
    works for me.
    Brilliant Mediocrity - Making Failure Look Good

  5. #5
    Linux User
    Join Date
    Oct 2004
    Location
    Serbia&Montenegro
    Posts
    281
    Have you just added ZaxisMapping option in xorg.conf?

  6. #6
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    Quote Originally Posted by Fallen Angel
    Have you just added ZaxisMapping option in xorg.conf?
    i have a logitech mouse, and I just added z axis mapping like adrenaline has
    I had to change
    Code:
    Option "Protocol" "whatever" to Option "Protocol" "IMPS/2"
    however
    Brilliant Mediocrity - Making Failure Look Good

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3

    working

    I got my mouse to work but now I would like to know how to get the scroll wheel working please and thanks you ahead of time

  8. #8
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407

    Re: working

    Quote Originally Posted by d34db0y
    I got my mouse to work but now I would like to know how to get the scroll wheel working please and thanks you ahead of time
    add the z axis mapping like myself and adrenaline mentioned.

    and fyi, no images allowed in sigs.
    http://www.linuxforums.org/rules.php
    Brilliant Mediocrity - Making Failure Look Good

  9. #9
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    zaxismapping does work in slackware, you may have to try "6 7" instead of "4 5" depending on how many buttons the mouse is, the wheel counts as three.
    Operating System: GNU Emacs

  10. #10
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Quote Originally Posted by adrenaline
    run xorg.conf and then edit /etc/X11/xorg.conf
    make a backup of your original conf file first
    cp xorg.conf xorg.conf.orig

    inside xorg.conf delete the part that looks like this one then add this there and reboot.

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Device" "/dev/mouse"
    Option "Protocol" "PS/2"
    Option "Emulate3Buttons" "off"
    Option "ZaxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "IMPS/2"
    Option "Emulate3Buttons" "off"
    Option "ZAxisMapping" "4 5"
    EndSection

    Let me know if this is not clear
    Sorry guys I should have been more clear - These configs are in my xorg.con file. where the mouse section goes. Mine happens to be a laptop. The first set is for the laptop and the second is for my external optical mouse of which the scroll works as well as the scroll button. I hope this clears it up a little. Hint though if you have a desktop with just the one mouse use the second set as I posted but try changing the Device to /dev/mouse or /dev/imput/mouse
    BTW the IMPS/2 should get the scroll to work along with the ZAxisMapping option. You might also try leaving the Emulate3Buttons out I really don't think it is needed but mine works so I am leaving it there.
    let me know if this is not clear

    Fallen Angel - Let me know if yours is still not working I will try and help you fix it.
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •