Hello,

I am trying to diagnose a problem / learn more. The issue that I am having
is with coreutils and the uname output.

Here is an extract of the problem

On Version A

address@bogus.example.com:~/build# /bin/uname -a
Linux poopey 2.6.10 #7 SMP Mon Dec 27 19:11:19 GMT 2004 i686 unknown
unknown GNU/Linux
address@bogus.example.com:~/build# /bin/uname --version
uname (coreutils) 5.2.1
Written by David MacKenzie.

Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
address@bogus.example.com:~/build#


As you can see on that version the processor and platform (-i and -p) show
unknown as the response.

However when I download the standard redhat rpm (rather than the version I
compiled from source) I get the following.

address@bogus.example.com:~/build# ./uname -a
Linux poopey 2.6.10 #7 SMP Mon Dec 27 19:11:19 GMT 2004 i686 i686 i386
GNU/Linux
address@bogus.example.com:~/build# ./uname --version
uname (coreutils) 4.5.3
Written by David MacKenzie.

Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


>As you can see from the second output I am gettin the -i and -p options
>printed. The only difference I can see initially is the version one is a
>redhat compiled binary and one is the source downloaded from the web.


address@bogus.example.com:~/build# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 8
model name : Pentium III (Coppermine)
stepping : 6
cpu MHz : 1000.033
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 mmx fxsr sse
bogomips : 1974.27

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 8
model name : Pentium III (Coppermine)
stepping : 6
cpu MHz : 1000.033
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 mmx fxsr sse
bogomips : 1998.84

address@bogus.example.com:~/build# cat /proc/version
Linux version 2.6.10 (address@bogus.example.com) (gcc version 3.3.4) #7 SMP Mon Dec 27
19:11:19 GMT 2004



I am trying to work out why this is the case and how I can work to resolve
the problem.

Any further information would be greatly appreciated.

Thanks