Find the answer to your Linux question:
Results 1 to 7 of 7
ok so problem is that i can't change to dir where my windows partition is mounted as normal user. As superuser : mount /dev/hda5 /mnt/d , and then i want ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    22

    can't change dir


    ok so problem is that i can't change to dir where my windows partition is mounted as normal user. As superuser : mount /dev/hda5 /mnt/d , and then i want to change to it as normal user but it says cannot change directory , permission denied, even if i chmod 777 /mnt/d i get the same error. If i umount the partition i can change to that directory.

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267

    Re: can't change dir

    Quote Originally Posted by kosmos
    ok so problem is that i can't change to dir where my windows partition is mounted as normal user. As superuser : mount /dev/hda5 /mnt/d , and then i want to change to it as normal user but it says cannot change directory , permission denied, even if i chmod 777 /mnt/d i get the same error. If i umount the partition i can change to that directory.
    If I understand correctly, you mounted a drive into /mnt/d then if you "cd /mnt/d" it doesnt work?
    can you cd to it with SuperUser?
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Is the drive NTFS or FAT32? If it is NTFS, try adding a line such as this to your /etc/fstab:
    Code:
    /dev/hda5 /mnt/d ntfs user 0 0
    and if it's fat:
    Code:
    /dev/hda5 /mnt/d vfat user 0 0
    That should work

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    22
    UgoDeschamps: yes i can cd to it as SuperUser
    lakerdonald: it is FAT partition and adding this line to /etc/fstab didn't helped.

    I have one more thing. When i mount it and go as normal user to XWindow i have icon od disk that is mounted on my desktop and i can open it with file manager ( autilius ) and i can see directories on that windows partition but when i want to open any dir i get : "couldn't open /mnt/d/other , the attempt to log in failed".

    edit: if i mount /dev/sr0 /mnt/cdrom i can cd to it as normal user.

  6. #5
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    After you added that line to the fstab, did you unmount and then remount the drive?

  7. #6
    Just Joined!
    Join Date
    Jan 2005
    Posts
    22
    i rebooted system.

  8. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    22
    Code:
    /dev/hda5   /mnt/d/   vfat   ro,user,unhide,noauto,umask=022
    and now everythig works .
    most important options are unhide and umask.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •