Find the answer to your Linux question:
Results 1 to 5 of 5
First off, I am not much more than a linux newbie. Here's my problem, I have managed to get slack to run perfect on my laptop except for sound(ver. 10.0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Ft. Lewis
    Posts
    10

    Sound in Slack...


    First off, I am not much more than a linux newbie. Here's my problem, I have managed to get slack to run perfect on my laptop except for sound(ver. 10.0 and 10.1). I can get only one application at a time to be able to access my soundcard (AC97 type soundcard) I know the problem is that there needs to be a mixer installed to mix the sound channels(?) from different applications. None of the howto's I've found on the net have helped. And also, I tried upgrading to kernel 2.6.10(from the slack disk and compiling my own from the source on kernel.org) Nothing has worked so far(kernel from the slack disk caused issues with my dvd/cdrw and none of the attempt compiling from source have booted properly) and I am at a total loss. What kind of information do you need to help me get ALSA up and running correctly.

  2. #2
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    What kind of laptop is it? I have a toshiba and my onboard sound conflicted with my onboard modem so I added the modem to the blacklist and ran alsaconf and then unmuted the sound in the mixer and mine started working.

    Tell us what kind of laptop and post your lsmod
    in a term type
    su -
    <password>
    lsmod
    then post the results.
    Mike
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Location
    Ft. Lewis
    Posts
    10

    re..

    Laptop is a Panasonic CF-50MB2FDKM. I have already blacklisted the driver for the modem in my blacklist. Here is my lsmod.

    Module Size Used by Not tainted
    snd-pcm-oss 36704 0 (unused)
    snd-mixer-oss 12152 0 [snd-pcm-oss]
    uhci 24284 0 (unused)
    ehci-hcd 17516 0 (unused)
    usbcore 58860 1 [uhci ehci-hcd]
    snd-intel8x0 18080 0
    snd-intel8x0m 8708 0
    snd-ac97-codec 52472 0 [snd-intel8x0 snd-intel8x0m]
    snd-pcm 54504 0 [snd-pcm-oss snd-intel8x0 snd-intel8x0m snd-ac97-codec]
    snd-timer 13412 0 [snd-pcm]
    snd 31268 0 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-intel8x0m snd-ac97-codec snd-pcm snd-timer]
    snd-page-alloc 4712 0 [snd-mixer-oss snd-intel8x0 snd-intel8x0m snd-pcm snd-timer snd]
    soundcore 3396 7 [snd]
    ohci1394 23888 0 (unused)
    ieee1394 41636 0 [ohci1394]
    8139too 13928 1
    mii 2272 0 [8139too]
    crc32 2880 0 [8139too]
    ds 6548 2
    yenta_socket 10436 2
    pcmcia_core 39172 0 [ds yenta_socket]
    ide-scsi 9392 0
    agpgart 45092 0 (unused)

    (I havent reinstalled ATI drivers sense I reloaded with 10.1)

    Also, here is what I get if try to run alsamixer

    No mixer elems found

  4. #4
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    I have noticed that the slax live cd has wonderful sound support, just boot into the slax live cd, and setup your alsa through a mixer and then "alsactl store" then copy the asound.state file to from the slax sysfiles to the slack sysfiles, not sure where it is right off hand but its pretty easy to find, and it should resolve any slackware sound issues...

    I had to do this with slackware sound myself, and it works like a charm though it is kind of a jury rig
    Operating System: GNU Emacs

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Location
    Dhaka, Bangladesh
    Posts
    6

    alsaconf

    Have you tried
    Code:
    alsaconf
    ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •