Find the answer to your Linux question:
Results 1 to 5 of 5
I have Windows XP, Mandrake 10.0 and Slackware 10.1 installed and I have the LILO bootloader. I just installed slackware and custom configured LILO in an attempt to be able ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4

    Won't boot into Slack...


    I have Windows XP, Mandrake 10.0 and Slackware 10.1 installed and I have the LILO bootloader. I just installed slackware and custom configured LILO in an attempt to be able to boot into both linux's but the only one that works is windows. when i try to boot Mandrake it boots Slackware and then gets to a prompt to login to something like "darkserver" or something? I don't have a username/password for this so I am stuck there sooo I try booting into Slack and get a fatal kernal error and something about "init" I might have specified the wrong partitions when configuring LILO anyway... how do I edit the config from windows? BTW my floppy drive does not work... How might a go about making a boot cd? maybe that would help... anyway, Thank you for any help you can offer.

    -Nathan

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    1
    my lilo is screwed right now between windows 2003 server and slack but if you usee the install CD if you did use cd .. use CD #1 and it will bring you to a boot screen.. you can either enter the setup or it tells you, you can boot into your linux by entering bare.i boot=/dev/hdb1 etc etc i dont remember the command wherever your slack is located then it will boot it for you.. thats what i do since my lilo is messed as well.

  3. #3
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    i'm not sure what you mean by the only one that works is windows, do you mean it's the only one that boots? it sounds like your mandrake booter is pointing to the partition that slackware is on, make sure that you know which partition is which and edit the config files accordingly.

    you probally mean darkstar which is the default name slackware gives a machine when you install it, this is fine, you'll need to log in as root using the password you gave the account during setup and then use the command adduser to add yourself a username and passwd to setup a password on that account, once that's done you can log into the account and then type startx to get your gui desktop enviroment running.

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Location
    Raleigh NC
    Posts
    4
    My Lilo is screwed too....

    i just let it boot from the cd and enter the "bare.i root=/dev/hda1 noinitrd ro" thing and it works fine

    i hardly ever shut it down neway, so its no big deal at all

  5. #5
    Just Joined!
    Join Date
    Feb 2005
    Location
    deep blu sea
    Posts
    17

    hmmmm....

    This probably wont help......
    But i'm bored, so what the hell.....

    I tried to boot linux from DOS using linux.bat and i got the kernel panic "init" message too... my problem was the linux batch file, by default the path for the two programs to start linux had \linux before the program name... But i had the batch in the same folder. So i took the "\linux" part away and it worked perfect. (so make sure it's pointing to the path were the programs exist)

    As for your login problem... Just login as "root" and make up a password.
    But you wont want to work in root too much if you're new to Linux...... type "adduser" to create a new user.

    Hope that helps,
    Invisible Pickle Monkey

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •