Find the answer to your Linux question:
Results 1 to 7 of 7
Hi everyone, i've just installed Slack 10.0 and everything went ok. The sound card is properly detected (nforce 2 cmedia ac97) but i do not hear any sound. XMMS works, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3

    Slackware 10.0 Sound Problem


    Hi everyone,
    i've just installed Slack 10.0 and everything went ok. The sound card is properly detected (nforce 2 cmedia ac97) but i do not hear any sound. XMMS works, the equalizer is jumping, but the sound does not come. The other multimedia applications do not produce any sound too. When i push the "Test Sound' button in the KDE control center, it does'n make any sound. Though no errors come out by trying to play a sound... What am i missing ?

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    in terminal type alsamixer, make sure none are muted. (if you have alsa)
    in terminal type kmix, make sure none are muted, try again.

    Any sound at all now?
    anything was muted?
    What media are you trying to play?
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3
    alsamixer - nothing is muted, except the PCM column, but i can't change it.
    kmix - everything seems to be ok, all values are set to max.

    I was trying to play mp3, but now i tried to play movies too - same thing (not sound, though it doesn't ouput erros.
    I tried with almoust all multimedia players available in the default installation, so maybe the problem isn't in the software.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Quote Originally Posted by Dolorian
    alsamixer - nothing is muted, except the PCM column, but i can't change it.
    Ok thats the problem, PCM and master are both required to play sound...

    Have you tryed to install the latest version of alsa?
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  6. #5
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    does anything appear when the os is starting up about alsa not working correctly ? It should be the last thing before login prompt (or it goes to kdm)
    Brilliant Mediocrity - Making Failure Look Good

  7. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3
    No, there are no errors. By typing 'lsmod', i see that 'audio' and 'soundcore' mods are runnig (if that does matter.

  8. #7
    Just Joined!
    Join Date
    Nov 2004
    Location
    Vienna, Austria
    Posts
    10
    [quote="Dolorian"]alsamixer - nothing is muted, except the PCM column, but i can't change it.

    To unmute - just press the M-Button!! and then the ESC.
    And to store the settings type

    alsactl store

    That should work - hopefully!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •