Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I just installed Slackware 10.1 on my other PC, but after I installed evrything etc.. It sayd that I could reboot my system, but when I reboot it without my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Jst
    Jst is offline
    Just Joined!
    Join Date
    Aug 2004
    Posts
    68

    Slackware 10.1 booting


    I just installed Slackware 10.1 on my other PC, but after I installed evrything etc.. It sayd that I could reboot my system, but when I reboot it without my bootdisk and the two rootdisks it says "No opertating system found". When I start it with the bootdisk, I only have like 15 commands i can use, I can't start X, I cant do anything.

    Tnx in advance for any help
    Jst.

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    Boot into Slackware using the CD (the instructions are on the very first screen you see when you put in the cdrom and start the computer) and, as root, run the program "liloconfig", choose simple, choose standard, choose MBR and install LILO and you should be fine and able to boot into Slackware without using the Slackware cdrom.

  3. #3
    Jst
    Jst is offline
    Just Joined!
    Join Date
    Aug 2004
    Posts
    68
    It doesnt support booting from a CD .

    Jst.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    Then you should try to do what I described using a bootdisk.

    This should also be helpful.

  6. #5
    Jst
    Jst is offline
    Just Joined!
    Join Date
    Aug 2004
    Posts
    68
    K, at the "boot:" part I typed "mount root=/dev/hda2" (without quotes), but when its almost done loading it says:
    Warning: Unable to open an initial console.
    Kernel panic: No init found. Try passing init= option to kernel.
    And it just freezes, i cant type anything from there..
    Jst.

  7. #6
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    Are you sure hda2 is the correct drive to boot off? cfdisk and fdisk might be of some use.

  8. #7
    Jst
    Jst is offline
    Just Joined!
    Join Date
    Aug 2004
    Posts
    68
    K, everything works now, I just used cfdisk to configure my partitions, formatted them and reinstalled all the packages and it worked.

    Now my second problem is that I cant change my resolution... It only shows 640x480, I want to have it at 1024x786 (or something like that).

    Tnx
    Jst.

  9. #8
    Jst
    Jst is offline
    Just Joined!
    Join Date
    Aug 2004
    Posts
    68
    I'm using the xorg.conf, I already try'd xorgcfg or xorgconfig, but it doesnt work .

    Jst.

  10. #9
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    xf86cfg should be able to fix that.

  11. #10
    Jst
    Jst is offline
    Just Joined!
    Join Date
    Aug 2004
    Posts
    68
    It says that the command is not found, but I'm not using xf86 (I think), I'm used to have xf86, but when I look at the /etc/X11/ dir it looks allot different.. The config is stored in xorg.conf for example..

    Jst.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •