Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, I have just installed a copy of Slackware for someone, and everything is working, including the winmodem etc , but I have a problem with my USB flash ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    12

    CLOSED: USB smartmedia not working (mods, please lock)


    Hi all,

    I have just installed a copy of Slackware for someone, and everything is working, including the winmodem etc, but I have a problem with my USB flash drive.

    Under Windows, my Smart media card, which is normally used by a digital camera, shows up all the images, which happen to be JPEGS.

    Under Slackware, however, I get the proceeding folders, but when I get to the folder in which the photographs are normally kept, I can't display them. This happens under both Konquror and the command line, and means that I can't access all my photos. Obviously, this is a big problem.

    My /etc/fstab looks like this:
    /dev/hda2 swap swap defaults 0 0
    /dev/hda1 / reiserfs defaults 1 1
    /dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0
    /dev/sda1 /mnt/camera auto noauto,user 0 0
    /dev/fd0 /mnt/floppy auto noauto,user 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0


    Thank you in advance for your help.

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Hi,
    /dev/sda1 /mnt/camera auto noauto,user 0 0
    this line in the fstab revel a good thing, its detected. can you look at the reading you get from
    Code:
    fdsik -l
    and see if the camera filesystem is detected (when pluged) also make sure that it under SDA1. Now, you have to know that since the fstab entry parameter field include the "noauto" flag, this meens that it will NOT mount it automaticly. You will have to mount it manually. I recommend using the noauto, specially on removable device, but thats up to you.

    You can have a look at this tutorial about getting usb flash drive to work, it'll explain all you need to know in details about your issue.

    Dont hesitate to ask if you require more information
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    12

    Finished

    Thanks, I have solved the problem. It wasn't linux at all (yeah!). The card had simply lost it's formatting, and couldn't be read by either Windows or Linux. Thanks UgoDeschamps for helping

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •