Find the answer to your Linux question:
Results 1 to 6 of 6
ok yes i am a linux newbie, as in starting 2 nights ago and not sleeping yet blah blah. i cant change the resolution from 1024x768 any way. i am ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Feb 2005
    Posts
    181

    the resolution problem


    ok yes i am a linux newbie, as in starting 2 nights ago and not sleeping yet blah blah. i cant change the resolution from 1024x768 any way. i am using kde and slackware 10.1. i have read lots of ways of fixing this problem, but so far nothing has worked for me. is there any way to force x to use a higher res? i have a geforce 3 and installed nvidia drivers. editing xorg.conf does nothing. any suggestions?

  2. #2
    Just Joined!
    Join Date
    Jan 2005
    Posts
    68
    Try this.

    As root edit with vim or emacs or elvis /etc/X11/xorg.conf, back it up first:

    Code:
    su -
    cd /etc/X11/
    cp xorg.conf xorg.confBackup
    emacs /etc/X11/xorg.conf
    Then edit this bit: (starts line 438 for me)

    Code:
        Subsection "Display"
            Depth       24
            Modes "1024x768" "800x600" "640x480"
        EndSubsection
    To:

    Code:
        Subsection "Display"
            Depth       24
            #Modes "1024x768" "800x600" "640x480"
             Modes "1280x1024"
        EndSubsection
    In emacs, hit F10, then press f, then s to write it.

    You can try higher resolutions if you want...

    Then quit kde

    Startx again

    Violla.

    If you get an error message when doing tartx after editing xorg.conf just use the xorg.conf you backed up, e.g:

    Code:
    su -
    cd /etc/X11/
    rm xorg.conf
    mv xorg.confBackup xorg.conf
    exit 
    startx
    Hope this helps

    <edit> Sorry, i should have read your original post a little better, what are you edititng in xorg.conf as this should do the trick??

  3. #3
    Linux Newbie
    Join Date
    Feb 2005
    Posts
    181
    yes this is one of the things i did, i tried it a few times (and replaced back ups a few times as well) but in the end, no matter how i could change it for the 24 depth or any other i end up getting the same options for res. maybe im going at it wrong? i go into xconfigure -desktop from kde and then try to modify the display, always getting a lot of lower resolutions.

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    68
    Backup your xorg.conf and run, as root:

    xorgconfig (you will need to know the vertical and horizontal refresh rates)

    See if that helps as it lets you specify your max resolution.

    Gl.

  5. #5
    Linux Newbie
    Join Date
    Feb 2005
    Posts
    181
    yeah i've ran this before, i will now run it again... when i run the program it only asks for h&v rates, never res. finishing that, still the options are the same. could it be something that i need to edit in the driver? i did notice a change once i install the driver, it makes a larger number of smaller resolutions become available.

  6. #6
    Linux Newbie
    Join Date
    Feb 2005
    Posts
    181
    ok oddly i found a fix!

    when lookin for a way to get it i found someone had the same problem just get rid of the vertical and horizontal refresh rates by stamping a # infront of each then restart x

    http://www.linuxforums.org/forum/topic-20611.html

    thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •