Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I have Nvidia Geforce MX 440 with 8x support (128Mb) and using slackware10.1+kernel2.6.10+fluxbox When i install nvidia drivers (kernel module) and start x , i get nvidia splashscreen and it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Lithuania
    Posts
    5

    nvidia splashscreen


    I have Nvidia Geforce MX 440 with 8x support (128Mb) and using slackware10.1+kernel2.6.10+fluxbox
    When i install nvidia drivers (kernel module) and start x , i get nvidia splashscreen and it doesn't hide, fluxbox is working normally, but on my screen still stand nvidia splashscreen.
    any help? =)

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    This may not exactly fix your problem, but there is an option to disable the splash screen using the nvidia-settings utility that comes with the official drivers.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    This is a known problem with the "6629" drivers. I have the same issue, also with Slack 10.1 and 2.6.10. It seems to especially effect the MX series. See this for a lot more. You might want to attempt dropping back to the "6111" driver. Please post back if you are successful getting 6111 installed. I've read that others have, but it keeps telling me I have the wrong kernel source, although I point it right to it and it is the right one. Nvidia says they plan to have this fixed in the next release, whenever that is...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2005
    Location
    Lithuania
    Posts
    5
    Quote Originally Posted by techieMoe
    This may not exactly fix your problem, but there is an option to disable the splash screen using the nvidia-settings utility that comes with the official drivers.
    The problem is that nvidia-settings working only when nvidia and X is working, as you know i can see anything when i run X with nvidia drivers =)
    thanx for help anyway =)

    Quote Originally Posted by Dapper Dan
    This is a known problem with the "6629" drivers. I have the same issue, also with Slack 10.1 and 2.6.10. It seems to especially effect the MX series. See this for a lot more. You might want to attempt dropping back to the "6111" driver. Please post back if you are successful getting 6111 installed. I've read that others have, but it keeps telling me I have the wrong kernel source, although I point it right to it and it is the right one. Nvidia says they plan to have this fixed in the next release, whenever that is...
    I think i better come back to older version of nvidia drivers =)
    thanx =)

  6. #5
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    i always got the nvidia splash screen on bootup untill i did this; in /etc/X11/xorg.conf under ' Section "Device" ' i added Option "NoLogo" "1"
    here's mine:
    Code:
    Identifier  "Card0"
    Driver      "nvidia"
    VendorName  "nVidia Corporation"
    BoardName   "NV20 [GeForce3]"
    BusID       "PCI:1:0:0"
    Option "DPMS"
    Option "NoLogo" "1"  # this disables the Nvidia splash screen
    hope that helps

  7. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Krendoshazin, did that effectively fix nvidia to where you could run 3D acceleration without problems?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  8. #7
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    i misread the question, i thought he was asking to get rid of the splash screen rather than the fact it froze at it. try this instead
    Code:
    Option "NvAGP" "3"
    change the number 3 to a number from 0 - 3

    "0" (uses no agp support)
    "1" (uses nvidia agpart only)
    "2" (tries kernel agpart only)
    "3" (tries kernel agp first, then nvidia agp)

  9. #8
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    just another thing to add; there's a whole selection of options for the nvidia drivers to add to xorg.conf, the address is
    ftp://download.nvidia.com/XFree86/Li...496/README.txt
    scroll down to the section titled ' (app-d) APPENDIX D: XF86CONFIG OPTIONS ' to see them all

  10. #9
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Thanks Krendoshazin. I tried the:

    Option "NoLogo" "1" # this disables the Nvidia splash screen

    ...and although it makes the nvidia logo go away, it is replaced by a black screen without any way to enter the DE. I'll look over that options list, but since this is a bug nvidia is working on, it may be we'll just have to wait for the next release.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  11. #10
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    perhaps /var/log/Xorg.0.log will shed some light on the problem, it contains all the messages from X like this;

    (II) NVIDIA(0): AGP 4X successfully initialized
    (II) NVIDIA(0): Setting mode "1600x1200"
    (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •