Find the answer to your Linux question:
Results 1 to 3 of 3
Before starting, have looked at many forums and googled to no avail. If there has been something posted previously, my apologies. Slack 10.0 is not recognizing my Gyration USB mouse ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    2

    Gyration USB Mouse, Xorg problems on Slackware 10.0


    Before starting, have looked at many forums and googled to no avail. If there has been something posted previously, my apologies.

    Slack 10.0 is not recognizing my Gyration USB mouse (of Gyration Ultra GT Suite w/ keyboard). I have tried all the configuration options (IMPS/2, auto, etc.). I have tried different input devices.To test, I even plugged in a Logitech MX310 usb mouse and it worked fine.

    The Gyration works fine for XFree86 on Mandrake 10 and a Knoppix boot disk. I tried copying those configuration options (typically IMPS/2 on /dev/input/mice) with no success.

    Thanks in advance for any help.

  2. #2
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666

    Re: Gyration USB Mouse, Xorg problems on Slackware 10.0

    Quote Originally Posted by emalone2183
    The Gyration works fine for XFree86 on Mandrake 10 and a Knoppix boot disk. I tried copying those configuration options (typically IMPS/2 on /dev/input/mice) with no success.
    now that is weird ...that was going to be my first sugestion!

    secound sugestion is this..try this config
    Code:
    Section "InputDevice" 
        Identifier   "Mouse0"
        Driver       "mouse"
        Option      "Protocol"   "auto"
        Option      "Device"     "/dev/input/mice"
        Option      "Buttons"   "5"
        Option      "ZAxisMapping" "4 5"
     EndSection
    when all else fails we try the 'auto" protocol
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    2

    Thank you loft!!

    Thank you very much! It worked! That had been bugging me for days.

    I am guessing the problem was that I needed to specify Mouse0, rather than Mouse1. It pretty much seems obvious now, but why would xorgconfig choose Mouse1? I had been curious as to how Linux interprets two USB input devices connected on one port (that is to say, the wireless receiver). Could that have been the problem?

    Again thanks, and I will definitely remember to pass that nugget on in the future.

    -E

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •