Find the answer to your Linux question:
Results 1 to 2 of 2
Hello. Im having trouble running firestarter. If I run it as a user, it says I need root privlidges, if i run it as root I get: Code: (firestarter:3587): Gtk-WARNING ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    68

    Firestarter help (user needs root perms. root needs display)


    Hello.

    Im having trouble running firestarter.

    If I run it as a user, it says I need root privlidges, if i run it as root I get:

    Code:
    (firestarter:3587): Gtk-WARNING **: cannot open display:
    I have tried:

    Code:
    xhost +localhost
    but, as root, get:
    Code:
    (firestarter:3603): Gtk-WARNING **: cannot open display:
    Is it possible to change which users have the rights to run an app? I have tried chmod 777. If not how can I add root to the display owners?

    Thanks much?

    <edit> if i "su root", i can run it but really dont wont to be doing this at all.

    Thanks again.

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Posts
    14
    I use firestarter too. I think that in not possible to run the program as user
    Read the firestarter-manual.pdf at page 3 .

    On the other hand I think is not a problem to run this program as root because it can be configured to start at boot time ... only the grafic parts (GUI) is started when you click icon or menu option.

    Before I installing firestarter I go to http://scan.sygatetech.com/ for security test and I observe that my TCP ports are closed but don't blocked .
    blocked means that my ports are stealth and my computer is not visible from internet

    After installing firestarter my TCP ports are stealth blocked with or without the GUI started. that means in my opinion that firestarter is started on boot time and works indpendently from grafical interface. The GUI I think is only a mode to display.

    I hope that will help you
    I use firestarter-1.0.3-i486-1pcx.tgz on slackware 10.1 and I install this package using Slackware installation tool

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •